Opened 7 years ago

Closed 7 years ago

#1002 closed defect/bug (fixed)

Initial state of route.route_status confusion

Reported by: wkcooper Owned by: cp15
Priority: minor Milestone:
Component: gui/internal Version: 0.0.4
Severity: Keywords:
Cc:

Description

Short description: on Navit startup with no destination defined route.route_status should be 0

Long description: From the documentation http://wiki.navit-project.org/index.php/OSD#Other_attributes it would appear that on startup and no route or destination defined navit should set route.route_status to 0. However on startup navit sets it to 2. Either the documentation needs to be updated as to what is returned by Navit during the phases or the route.route_status function needs to be updated to return 0.

Tested on both navit for android and Linux

Change History (4)

comment:1 Changed 7 years ago by wkcooper

  • Priority changed from major to minor

Mistake made in original report, initial route_status = 1, indicating a destination is set.

comment:2 follow-up: Changed 7 years ago by korrosa

I'm sure this isn't the case, but just checking: when you quit Navit, is a route still active? If so, the next time Navit starts up it will re-route to the same destination.

There was a bug introduced a couple of commits back which screwed this feature up, but it got fixed. It'd also be good to know what version of Navit you're using (i.e. where you got it from? SVN? Package maintainer? Market?)

comment:3 in reply to: ↑ 2 Changed 7 years ago by wkcooper

You are correct, it was an older SVN build from late last year. On updating and recompiling the results are what the documentation said. On the most recent Android version I have (4892 from SVN download) problem is also resolved.

Thanks for the attention.

Replying to http://wiki.navit-project.org/index.php/user:korrosa:

I'm sure this isn't the case, but just checking: when you quit Navit, is a route still active? If so, the next time Navit starts up it will re-route to the same destination.

There was a bug introduced a couple of commits back which screwed this feature up, but it got fixed. It'd also be good to know what version of Navit you're using (i.e. where you got it from? SVN? Package maintainer? Market?)

comment:4 Changed 7 years ago by sleske

  • Resolution set to fixed
  • Status changed from new to closed

As the problem is resolved in recent versions, I'm closing this.

Note: See TracTickets for help on using tickets.