Opened 7 years ago

Closed 7 years ago

#1009 closed defect/bug (fixed)

Routing to wrong lane with opposite direction

Reported by: crystalgfan . Owned by: cp15
Priority: major Milestone:
Component: mapdrivers/OSM Version: git master
Severity: Keywords: Routing to wrong lane
Cc:

Description

Hi all,
I'd like to know why Navit leads me to the wrong lane with opposite direction.
Try to route from Kroppenstedt to Egeln Nord in Germany on B81.
At the point where the B81 splits up to a 4 lane road with 2 lanes for each direction then Navit leads me to the northern part, but that's the wrong lane.
osm IDs are: coming from 10555638 Navit routes to 10275504 but the correct one would be 10551665
This happens with a map downloaded recently, on 2012-02-01, taken from here:
http://maps.navit-project.org/api/map/?bbox=5.185546875,46.845703125,15.46875,55.634765625[[BR]] With a map taken on 2011-10-25 it routes correctly with the same Navit version, svn-4905.
What is wrong here or what has to be done with the osm data? Attached a screen capture.

Attachments (1)

Demo_B81.jpg (82.1 KB) - added by crystalgfan . 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by crystalgfan .

comment:1 Changed 7 years ago by korrosa

I can't see anything wrong with the OSM data (http://www.openstreetmap.org/?lat=51.94122&lon=11.40716&zoom=17&layers=M).

You may want to try re-downloading a Navit map, as map updates on the Navit server broke down recently - it could be that you have a slightly corrupted map.

Are you travelling from East to West?

comment:2 follow-up: Changed 7 years ago by tegzed

Hi Crystalgfan,

I think the maps that are downloaded from maps-navit-project are created with an old version of maptool or from older map data. With these maps I could reproduce the error. With maps created from recent osm files with the latest maptool the problem disappears.

comment:3 in reply to: ↑ 2 Changed 7 years ago by crystalgfan .

Replying to http://wiki.navit-project.org/index.php/user:tegzed:

With maps created from recent osm files with the latest maptool the problem disappears.

Hi korrosa, hi tegzed,

Thanks for reply.
I'm travelling from West to East.

I tried to process OSM Maps myself according to the wiki:
http://wiki.navit-project.org/index.php/OpenStreetMap#Processing_OSM_Maps_Yourself
but I'm not pleased with the results.
What I could test, the export from OpenStreetMap? did work well with maptool and I can verify that the routing is correct then.
Taking data from Geofabrik worked fine also for a small map like the one for Sachsen-Anhalt.
Then trying the Germany map maptool always brings this error:

C:\Programme\navit\bin>maptool -i germany.osm my_Navit_map.bin SPAGE_SIZE: 4096, SVALIGN:33554432[[BR]] return dwTlsIndex = 0x2
PROGRESS: Phase 1: collecting data 0:01
PROGRESS1: Processed 0 nodes (0 out) 0 ways 0 relations 0 tiles 0:01
flush_nodes 0
realloc of 872415232 bytes failed

What else can I do to process the whole Germany map?

comment:4 follow-up: Changed 7 years ago by tegzed

Hi crystalgfan,

How much memory do you have? To process large maps you need somewhat more than 1GB of free memory. By default maptool splits large inputs to 1GB chunks.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 7 years ago by crystalgfan .

Replying to http://wiki.navit-project.org/index.php/user:tegzed:

How much memory do you have?


Hi tegzed,

It was an XP machine with 2GB RAM.
Now I'm on a Win7 Notebook with 8GB but the same result:
C:\NAVIT>maptool -i germany.osm my_Navit_map.bin
SPAGE_SIZE: 4096, SVALIGN:33554432[[BR]] return dwTlsIndex = 0x1
PROGRESS: Phase 1: collecting data 0:00
PROGRESS1: Processed 0 nodes (0 out) 0 ways 0 relations 0 tiles 0:00
flush_nodes 0
realloc of 872415232 bytes failed

maptool is from win32 cmake svn 4918

edit:
maptool is now taken from /navit/win32/svn 4929
Just tested the smaller file sachsen-snhalt.osm and that worked well.

Using the -S option and the big germnay file then this is the output:
C:\NAVIT>maptool -S 500000000 -i germany.osm my_map.bin
SPAGE_SIZE: 4096, SVALIGN:33554432[[BR]] return dwTlsIndex = 0x1
PROGRESS: Phase 1: collecting data 0:00
PROGRESS1: Processed 0 nodes (0 out) 0 ways 0 relations 0 tiles 0:00
flush_nodes 0
flush_nodes 0
flush_nodes 0
PROGRESS1: Processed 92503633 nodes (3367985 out) 13704363 ways 214414 relations 0 tiles 11:45
flush_nodes 1
PROGRESS: Phase 2: counting references and resolving ways 11:59
4 slices
slice 0 of 3
slice 1 of 3
slice 2 of 3
slice 3 of 3
PROGRESS: Phase 3: converting ways to pois 13:22
PROGRESS: Phase 4: finding intersections 13:22
PROGRESS4: Processed 0 nodes (0 out) 0 ways 0 relations 0 tiles 13:22
PROGRESS4: Processed 0 nodes (0 out) 13882415 ways 0 relations 0 tiles 13:34
PROGRESS4: Processed 0 nodes (0 out) 0 ways 0 relations 0 tiles 13:34
PROGRESS4: Processed 0 nodes (0 out) 18578121 ways 0 relations 0 tiles 14:04
maptool:tempfile_rename:/work/compile/navit/src/navit/maptool/tempfile.c:62 asse rtion failed:rename(buffer_from, buffer_to) == 0

Last edited 7 years ago by crystalgfan . (previous) (diff)

comment:6 in reply to: ↑ 5 Changed 7 years ago by crystalgfan .

Hi,

I'm going to stop the search here because the map that I can get now from the link in my first post does the mentioned routing ok.

comment:7 Changed 7 years ago by crystalgfan .

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.