Opened 11 years ago

Closed 9 years ago

#101 closed defect/bug (fixed)

Turn restrictions are ignored

Reported by: Schwabenbraeu Owned by: cp15
Priority: critical Milestone: version 0.2.0
Component: core Version: git master
Severity: Keywords:
Cc:

Description (last modified by Singesang)

Navit calculates an illegal route when trying to navigate from N47.713567 E9.080216 to N47.711728 E9.080378: It proposes to turn left at N47.7124 E9.0825 but there is a pesky bridge.

In addition, navit wants to "u-turn" at N47.7114 E9.085 when trying to travel in the reverse direction.

I'm using the maps from Marco Polo Grosser Reiseplaner 2007-2008 btw.

Change History (7)

comment:1 Changed 11 years ago by KaZeR

  • Component changed from core to mapdrivers/M&G
  • Milestone set to version 0.1.0
  • Owner changed from somebody to cp15

comment:2 Changed 10 years ago by Singesang

I can't reproduce this bug with osm maps but the u-turn thing is reproducable with osm maps

comment:3 Changed 10 years ago by Singesang

  • Component changed from mapdrivers/M&G to core
  • Description modified (diff)
  • Summary changed from Illegal route calculated to Turn restrictions are ignored

Modified due to #135

comment:4 Changed 10 years ago by kazer

  • Resolution set to worksforme
  • Status changed from new to closed

Turn restrictions should work with OSM maps from r2567.

Not planned to be implemented for M&G, patch welcome if you need it.

comment:5 Changed 9 years ago by mirko

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version set to svn

Hi,

I reopen this ticket as I encountered the same bug again in r3086:

I've installed r3086 and OSM maps, yesterday. If I drive on Münsterstraße in Düsseldorf, Germany (sorry for the special characters :P ) to the North, Navit wants me to turn left into Grashofstraße. As you can see here: http://osm.virtuelle-loipe.de/restrictions/?zoom=17&lat=51.25071&lon=6.80128&layers=B00TT , this is not allowed and seems to be implemented correctly in OSM.

Mfg

Mirko

PS: Platform: Openmoko Neo Freerunner (OM 2008, Linux 2.6.24)

comment:6 Changed 9 years ago by tegzed

Martin-s's modification at 2010-06-17 08:55 (r3363) seems to solve this issue for the cases I tested (no_turn_left and only_straight_on type TRs).

MFG

David Tegze

comment:7 Changed 9 years ago by kazer

  • Resolution set to fixed
  • Status changed from reopened to closed

Thanks for the report, David.

Note: See TracTickets for help on using tickets.