Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1014 closed defect/bug (worksforme)

navit unable to use planet.bin as map file

Reported by: zoff99 Owned by: sleske
Priority: major Milestone: want patch / contribution
Component: mapdrivers/OSM Version: git master
Severity: Keywords:
Cc: dado.josipovic@…, sebastian.leske@…

Description

navit has problems reading planet.bin as mapfile

navit used: svn-4936 for win32

planetbin used: 08.02.2012

ist the code broken or the planet file?

00:24:50.277|map_binfile:map_binfile_open:file_create T:\pl\planet-120208.bin
00:24:50.277|speech_espeak:speech_message_handler:message_handler called
00:24:50.277|speech_espeak:speech_message_handler:message_handler called
00:24:50.277|speech_espeak:speech_message_handler:message_handler called
00:24:50.277|navit:file_create:fd=4
00:24:50.277|navit:file_create:size=-1
00:24:50.277|speech_espeak:speech_message_handler:message_handler called
00:24:50.293|map_binfile:binfile_read_eoc:sig 0xa
00:24:50.293|map_binfile:binfile_read_eoc:eoc signature check failed: 0xa vs 0x6054b50
00:24:50.293|map_binfile:map_binfile_zip_setup:unable to read eoc
00:24:50.293|map_binfile:map_binfile_open:invalid file format for 'T:\pl\planet-120208.bin'

Change History (14)

comment:1 Changed 7 years ago by tryagain

Looks like file is truncated.

What's actual file size?

What media and filesystem is used to hold planet.bin?

comment:2 Changed 7 years ago by zoff99

ntfs, size over 8GB.

you can easily try it for yourself on a windows box

comment:3 Changed 7 years ago by sleske

If the file was somehow corrupted/truncated, that's easy to check. A Navit bin file is a ZIP file, so just test the ZIP integrity, e.g. using "unzip -vt planet.bin".

If this fails, the file is corrupt. If it does not, the problem may be with Navit.

If the file is corrupt, try a fresh download. The planet extractor had issues a few days ago, I believe.

comment:4 Changed 7 years ago by dado josipovic

Have a similar issue:

Navit log started
navit:file_wordexp_new:wordexp('W:\Tools\navit\navit-svn-5160\data/bookmark.txt') returned 1
navit:navit_new:return 023EDE58
navit:navit_ref:refcount 2
binding_win32:win32_main_navit:enterbinding_win32:win32_main_navit:enter2vehicle_file:vehicle_file_new_file:on_eof=0
navit:vehicle_ref:refcount 2
navit:vehicle_unref:refcount 1
navit:tracking_ref:refcount 2
navit:tracking_unref:refcount 1
speech_espeak:espeak_new:path_home set to W:\Tools\navit\navit-svn-5160/espeak-data
speech_espeak:espeak_new:Testing W:\Tools\navit\navit-svn-5160/espeak-data/voices/nl-be and W:\Tools\navit\navit-svn-5160/espeak-data/voices/nl/nl-be
speech_espeak:espeak_new:Language full nl-be lang nl result nl
map_binfile:binfile_read_eoc:eoc signature check failed: 0x17 vs 0x6054b50
map_binfile:map_binfile_zip_setup:unable to read eoc
map_binfile:map_binfile_open:invalid file format for 'W:\Tools\navit\navit-svn-5160/maps/osm_bbox_2.4,39.6,20.1,53.0.bin'
graphics_win32:create_memory_dc:resize memDC to: 792 547 
navit:tracking_ref:refcount 2
navit:file_wordexp_new:wordexp('W:\Tools\navit\navit-svn-5160\data/destination.txt') returned 1
navit:navit_unref:refcount 1
navit:main_real:Using config file 'navit.xml'
graphics_win32:event_win32_main_loop_run:enter
graphics_win32:create_memory_dc:resize memDC to: 26 26

Last edited 7 years ago by dado josipovic (previous) (diff)

comment:5 Changed 7 years ago by dado josipovic

  • Cc dado.josipovic@… added

comment:6 Changed 7 years ago by sleske

  • Owner changed from cp15 to sleske

map_binfile:binfile_read_eoc:eoc signature check failed: 0x17 vs 0x6054b50 map_binfile:map_binfile_zip_setup:unable to read eoc

This means that the file is not a valid ZIP file (and thus not a valid binfile).

Where did you get the file? If you created it yourself with maptool, please try to reproduce it with a recent maptool, and post the input data. If you downloaded it, post where.

comment:7 Changed 7 years ago by dado josipovic

From the website in the wiki...

I renamed it to zip, and winrar-test reports the zip-container is OK.

(The GTK GUI doesn't work either... "no GUI". Installing GTK+ doesn't help.)

comment:8 Changed 7 years ago by sleske

From the website in the wiki...

Very funny. The wiki links dozens of websites. Please post a link for the file. Or, even better, upload the file somewhere (a file hoster, if need be), and post that link here. (Please do not attach it to trac, unless it's only one or two MB...).

Also, if you downloaded the file a while ago, re-download it and re-check - it might simply have been a damaged file.

(The GTK GUI doesn't work either... "no GUI". Installing GTK+ doesn't help.)

Yes, it does - I use it daily. If it does not work for you, please post a separate bug report, and we'll see...

comment:9 Changed 7 years ago by dado josipovic

I downloaded it from http://maps5.navit-project.org/. I made my own selection.

I don't have the file anymore, but I assume that it is reproducable as it happend with any file I downloaded.

I downloaded the "entire planet" from here: http://wiki.navit-project.org/index.php/OpenStreetMap and that does work...

comment:10 Changed 7 years ago by sleske

Thank you. It looks like http://maps5.navit-project.org/ is having problems:

  • When I make a selection there, the download size shown is always at least about 60-70 MB - even if I select a tiny patch of emtpy ocean. I have only tried two test downloads, but there I really got a file of that size, so it's not just a display problem.
  • I unpacked one sample download (from south Germany), and the binfile contained over 300.000 individual files, almost all of which were empty. Normally, the number of files should correspond to the area the file covers (so only a few 1100 files for a small area), and there should be no emtpy files.

I'm afraid the map extractor is broken :-/. I'll post about it on IRC, and try to find out who can fix it. In the meantime, your best bet is probably to download OSM data directly, and convert it yourself using maptool.

About your GTK+ problem: GTK+ GUI should work out-of-the-box, at least on Linux, if libs are installed. If not, feel free to ask on IRC, or post a bug report.

comment:11 Changed 7 years ago by tryagain

Sleske, zero-sized tiles is a feature. Please read http://wiki.navit-project.org/index.php/Navit%27s_binary_map_driver#How_to_extract_a_specific_area_from_this_map_format

Have no exact knowledge of minimal file size, but it's quite probably we have something that big placed into every map excerpt.

comment:12 Changed 7 years ago by sleske

Thanks tryagain, I didn't know about this trick. So the maps are probably ok.

I downloaded a fresh map from the map extractor today, and tested it. It works for me (SVN r5163, Debian Linux on i386): the map is shown, I get no error messages about zip errors.

I have uploaded this map here: https://rapidshare.com/files/3442022272/osm_bbox_8.3_50.0_9.1_50.3.bin (link should remain valid for 30 days).

Please download this file. It's a map of Frankfurt/Main? (Germany). Use it as a map in Navit, then go to address search, country "Germany", city "Frankfurt am Main", then "view on map". You should see the center of Frankfurt.

If this works, you probably just had a bad map download (for whatever reason). If it does not, then maybe there's a problem with Navit. Then please tell us what version of Navit you are using, and retry with the latest SVN version.

Last edited 7 years ago by sleske (previous) (diff)

comment:13 Changed 7 years ago by sleske

  • Resolution set to worksforme
  • Status changed from new to closed

Since there has been no reply from the reporter for over 8 weeks, I'm closing this bug as "worksforme".

If the problem reappears, feel free to reopen this ticket.

comment:14 Changed 6 years ago by sleske

  • Cc sebastian.leske@… added
Note: See TracTickets for help on using tickets.