Opened 5 years ago

Closed 4 years ago

#1017 closed defect/bug (fixed)

Describe on Wiki ability to call external application/program

Reported by: bino Owned by: KaZeR
Priority: minor Milestone: want patch / contribution
Component: core Version: git master
Severity: Keywords: cli, command, osd
Cc:

Description

Dear All ...

It'll be great if Navit can call external program.

Let's say something like :

<osd enabled="yes"  
    type="button" x="0" y="0" 
    command="gui.excall('/usr/local/bin/myprog')" 
    comment="'param1' 'param2'"
    src="mybutton.xpm"
/>

And when pressed/clicked , navit will call it in a fire and forget manner. just like :

bino@bino$ /usr/local/bin/myprog 'param1' 'param2' &

I'm prettysure that with this, user can extend Navit using their own programming language preference (python, perl, ruby, etc etc)

Sincerely -bino-

Change History (5)

comment:1 Changed 5 years ago by tryagain

  • Milestone changed from To be discussed - Give your opinion! to want patch / contribution
  • Summary changed from ability to call external application/program to Describe on Wiki ability to call external application/program
  • Type changed from enhancement/feature request to defect/bug

Bino, we already have that feature. Just use

<osd enabled="yes"  
    type="button" x="0" y="0" 
    command='spawn("/usr/local/bin/myprog","param1","param2")' 
    src="mybutton.xpm"
/>

Leaving the ticket opened to update wiki documentation.

comment:2 Changed 5 years ago by zoff99

seems to be duplicate of ticket:461

comment:3 Changed 5 years ago by korrosa

I have started a complete re-write of the Configuring Navit page on the wiki (http://wiki.navit-project.org/index.php/User:Korrosa/Configuring_Navit). I will add this information into the 'Advanced' section.

(I did start this page a while back and then got sidetracked - I'll try and finish it soon!)

comment:4 Changed 5 years ago by mvglasow (2)

Are you aware of http://wiki.navit-project.org/index.php/The_Navit_Command_Interface, which documents all the commands available from the menu and OSD? I just added it there, maybe someone can have a look at it and correct/extend it if necessary - I am not sure about some things.

Last edited 5 years ago by mvglasow (2) (previous) (diff)

comment:5 Changed 4 years ago by usul

  • Keywords cli command osd added
  • Priority changed from major to minor
  • Resolution set to fixed
  • Status changed from new to closed

both aspects seem to be fullfilled, so ticket closed. If I missed something, please reopen it. Thanks for you folks :)

Note: See TracTickets for help on using tickets.