Opened 12 years ago

Closed 12 years ago

#102 closed defect/bug (invalid)

Navit (SDL) crashes when GPS receiver connected

Reported by: sk <stefan.klumpp@…> Owned by: KaZeR
Priority: major Milestone: version 0.1.0
Component: gui/gtk Version: git master
Severity: Keywords:
Cc:

Description

Navit (latest cvs) crashes using the SDL interface when GPS receiver is connected. Works flawlessly with GTK.

First try: http://pastebin.com/m88ac3ea

After deleting destination.txt: http://pastebin.com/maf0ccc3

Change History (3)

comment:1 Changed 12 years ago by KaZeR

  • Milestone set to version 0.1.0
  • Owner changed from KaZaR to KaZeR
  • Status changed from new to assigned

comment:2 Changed 12 years ago by anonymous

  • Component changed from gui/cegui to gui/gtk

confirmed! please fix it. NavIT is unusable with this bug. It doesn't work with gtk, too.

comment:3 Changed 12 years ago by KaZeR

  • Resolution set to invalid
  • Status changed from assigned to closed

Pastebin has expired, so we can't access the backtrace. If the bug still occurs in gtk, please repost a backtrace.

Simply paste it in your comment, and surround it by triple { (or use the code block button).

I close the ticket because : 1) sdl won't be fixed for now, and might be dropped in favor of a new gui soon (wip) 2) bug hasn't been reproduced using gtk.

Please reopen the ticket if you see fit.

Note: See TracTickets for help on using tickets.