Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1039 closed defect/bug (worksforme)

Flood of "easily turn" with android

Reported by: ziaou Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: turn, android, description
Cc:

Description

Route description is flooded by "easy turn" indications (see attachment). it seems to generate 1 turn indication at each segment of the road. I observed this issue :

but not :

  • on linux svn 5105 built by myself

I've tested with the same map from navit planet extractor.

Corresponding map area : http://www.openstreetmap.org/?lat=43.77265&lon=1.69566&zoom=17&layers=M

speech navigation is very painful in these conditions :)

Attachments (3)

navit-route_description.png (83.2 KB) - added by ziaou 5 years ago.
Navit route description with turn flooding
Route_Graph.png (75.1 KB) - added by ziaou 5 years ago.
Navit screen with route graph enabled
Route_Graph_and_Nav.png (84.2 KB) - added by ziaou 5 years ago.
Route Graph and nav screenshot

Download all attachments as: .zip

Change History (29)

Changed 5 years ago by ziaou

Navit route description with turn flooding

comment:1 Changed 5 years ago by ziaou

Issue not reproduced with android version available on google play (0.5.0 4785-)

comment:2 Changed 5 years ago by ziaou

Tested with navit 5109 and android SDK emulator, the issue is reproduced

comment:3 Changed 5 years ago by crystalgfan .

Same issue here, routing is un-usable.

latest svn 5106 taken from here: /navit/android_armv5te/svn

2.2.1 Froyo Custom Rom

comment:4 Changed 5 years ago by tryagain

Tested with 5106 on my region - can't reproduce, but I use a pretty old map.

Can you please attach a screenshot of navit screen with route and route graph (Settings->Map->route graph) displayed.

Changed 5 years ago by ziaou

Navit screen with route graph enabled

comment:5 Changed 5 years ago by me.yahoo.com/a/fqumtoocke.0wilto.h_6no77cyxna--#a909b

Same issue, this appeared with the Sunday's latest droid version (5106, I believe). This issue was not present on the older version I had. Not much help, but at least it localizes which changes it was a little!

comment:6 Changed 5 years ago by tryagain

Hi.

Cant reproduce this even with current map of that region downloaded from the planet extractor.

You're using a customized navit.xml. Have you tried to reproduce that with the default one?

Maybe you have something special inside <announce> or <speech> tags?

comment:7 Changed 5 years ago by wkcooper

Hello
I have encountered the error with and without a custom navit.xml file on android. The software seems to be directing me to every point on the road, it says to turn gently left when the road begins to bend left or other directions on seemingly straight roads.
I think I first detected the problem with nightly build 5104.

Other information
Device - Samsung GT S5830L Galaxy Ace
OS - Android 2.3.4
Example area - http://www.openstreetmap.org/?lat=10.64732&lon=-61.4025&zoom=16&layers=M anywhere along the Eastern Main Road

Hope that helps

Last edited 5 years ago by wkcooper (previous) (diff)

comment:8 follow-up: Changed 5 years ago by tryagain

Does anybody know some version that were definitely working well?

Am I right that the problem also shows itself by a very long "route description" page as shown in the earlier attached screenshot http://trac.navit-project.org/attachment/ticket/1039/navit-route_description.png ?

Changed 5 years ago by ziaou

Route Graph and nav screenshot

comment:9 follow-up: Changed 5 years ago by ziaou

After enabling all the layouts in the navit configuration, we can see that a turn indication is sent for each road intersection rather than each road point :

http://trac.navit-project.org/attachment/ticket/1039/Route_Graph_and_Nav.png

I will try to find the first build with this issue between 5104 and 4785 :)

comment:10 in reply to: ↑ 9 Changed 5 years ago by wkcooper

Hello you are right about the intersections and not road points, good catch. I have just been checking using your method (displaying all layouts) to check the android versions I have downloaded, the last version without a problem seems to be nightly 5038.
Hope that helps.

comment:11 in reply to: ↑ 8 Changed 5 years ago by wkcooper

Replying to http://wiki.navit-project.org/index.php/user:tryagain:

Does anybody know some version that were definitely working well?

Am I right that the problem also shows itself by a very long "route description" page as shown in the earlier attached screenshot http://trac.navit-project.org/attachment/ticket/1039/navit-route_description.png ?

Hello I did not notice that before, yes I also have the very long route descriptions on the floody versions.

comment:12 Changed 5 years ago by ziaou

After building many version of navit, my results are :

  • 5044 : issue not reproduced
  • 5049 : issue reproduced
  • 5045 to 5048 : not able to run Navit, gps icon in notification bar toggles ON/OFF and navit can't start

I noticed also that in build 5049, the map file appears twice in the "Configuration > Maps" menu, one time on top and one time on bottom of the list. It is not the case in the 5044 build. I don't know if t is a normal behavior but it looks strange.

The list of modified files between 5044 and 5049 (svn diff -r 5049:5044) :

  • navit/android/src/org/navitproject/navit/NavitGraphics.java
  • navit/android/src/org/navitproject/navit/Navit.java
  • navit/android/src/org/navitproject/navit/NavitDialogs.java
  • navit/android/src/org/navitproject/navit/NavitDownloadSelectMapActivity.java
  • navit/android/src/org/navitproject/navit/NavitTextTranslations.java
  • navit/android/src/org/navitproject/navit/NavitMapDownloader.java
  • navit/android/res/values/strings.xml
  • navit/android/res/values-fr/strings.xml
  • navit/android/res/values-de/strings.xml
  • navit/android/res/values-nl/strings.xml
  • navit/maptool/osm.c
  • navit/android.c

comment:13 follow-up: Changed 5 years ago by pour cyril

I also have the problem, so I downgraded to market version. Where do you get old versions from? Could someone drop version 5044 somewhere so I can download/install it on my device (Android 1.6)? Thanks

Last edited 5 years ago by pour cyril (previous) (diff)

comment:14 in reply to: ↑ 13 ; follow-up: Changed 5 years ago by ziaou

Replying to pour cyril:

Where do you get old versions from? Could someone drop version 5044 somewhere so I can download/install it on my device (Android 1.6)? Thanks

I built all version from svn repository (svn update -r 5044)

comment:15 in reply to: ↑ 14 ; follow-up: Changed 5 years ago by pour cyril

Replying to https://wiki.navit-project.org/index.php/user:ziaou:

I built all version from svn repository (svn update -r 5044)

I don't have the building packages installed. Would you mind to put your apk somewhere on the Internet?

comment:16 in reply to: ↑ 15 ; follow-up: Changed 5 years ago by ziaou

Replying to pour cyril:

I don't have the building packages installed. Would you mind to put your apk somewhere on the Internet?

Build 5044 available at : http://dl.free.fr/i15lUyclh

comment:17 in reply to: ↑ 16 Changed 5 years ago by pour cyril

Build 5044 available at : http://dl.free.fr/i15lUyclh

Super, merci !

comment:18 Changed 5 years ago by tryagain

Hi!

I think I have found both the cause and soulution.

Rikky recently made navit binary automatically use navitmap.bin by android port if the file is placed to /sdcard/navit.

In a later commit, he have removed the reference to navitmap.bin from android navit[hml]dpi.xml placed in apk.

So current version of navit in its default configuration shouldnt have this behavior. And if you use a custom navit.xml, you should remove from it reference to navitmap.bin or move your file to some nondefault location so it won't be referenced by new automagic.

That automagic should be documented on the wiki if that is not yet done.

comment:19 Changed 5 years ago by me.yahoo.com/a/fqumtoocke.0wilto.h_6no77cyxna--#a909b

I have a custom xml. Moving navitmap to a new subfolder, and changing the xml, as suggested seems to have cleared up the directions! :)

comment:20 Changed 5 years ago by pour cyril

Can you be a bit more precise in the problem? I use a file map called bretagne.bin in /sdcard/navit, that file is called in the custom navit.xml, no call to navitmap.bin and I still have the problem when I use SVN 5114. Anything else to changed?

Edit: I removed the call to bretagne.bin, it works fine, so actually it looks for any ".bin" file. Do you know if it looks also for the csv files?

Last edited 5 years ago by pour cyril (previous) (diff)

comment:21 Changed 5 years ago by tryagain

Sorry for a misleading comment, it's really looking for the .bin files. Here you are the corresponding java code:

http://navit.svn.sourceforge.net/viewvc/navit/trunk/navit/navit/android/src/org/navitproject/navit/NavitMapDownloader.java?annotate=5045&pathrev=5045#l633

It doesn't touch any csv files.

Last edited 5 years ago by tryagain (previous) (diff)

comment:22 Changed 5 years ago by tryagain

And, don't forget, everything above is related to android port only.

comment:23 Changed 5 years ago by ziaou

  • Resolution set to worksforme
  • Status changed from new to closed

It works fine with :

  • build 5114
  • map file from planet extractor stored as /sdcard/navit/navitmap.bin
  • no reference to navitmap.bin in navit.xml

comment:24 Changed 5 years ago by korrosa

I have updated the wiki main page regarding this ticket. I will also be updating the Android page on the wiki to reflect the recent changes. Thanks for bringing this to our attention!

comment:25 follow-up: Changed 5 years ago by martin bruns

The problem pops up every time you have more than one bin file in your navit.xml. I only tested overlapping maps on linux and android.

Unfortunately this makes then new nice android map download feature unusable. Since there are always overalpping parts. e.g. download the map for germany and benelux and you will see it.

navit needs to "see" the overlapping and react on this.

comment:26 in reply to: ↑ 25 Changed 5 years ago by tryagain

Replying to martin bruns:

navit needs to "see" the overlapping and react on this.

Thats another story for another ticket. This one is already closed.

I've added a new one: #1046.

Last edited 5 years ago by tryagain (previous) (diff)
Note: See TracTickets for help on using tickets.