Opened 8 years ago

Closed 8 years ago

#1048 closed enhancement/feature request (duplicate)

Split up config file

Reported by: me.yahoo.com/a/8osazsp9onby_vzgih2bn_5vq3i272m.dejjjq--#8352e Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Hi,

the ability to customize NAVIT is quiet impressive. Unfortunatly this causes a real big navit.xml config file, mixing all parts of propertie (GPS, GFX, Menu, ...) and blown up with a lot of comments and stuff that needs to be (de)activated for vatious platforms.

My suggestion is to split up the file into config files that can be easily maintained and exchanged. For example this results in

  • gfx.xml - for choosing GFX backend and visualisation
  • menu.xml - for OSD and menu aspects
  • navigation - for GPS, routing and voice aspects

Hopefully this will make it easier to deploy builds that are customized for the spec. platforms and to easily add other themes etc.

Change History (1)

comment:1 Changed 8 years ago by korrosa

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #373

Note: See TracTickets for help on using tickets.