Opened 7 years ago

Closed 6 years ago

#1057 closed defect/bug (fixed)

OSD items display on top of menu when enabled by cmd_interface

Reported by: mvglasow (2) Owned by: Singesang
Priority: minor Milestone:
Component: osd/core Version: git master
Severity: Keywords:
Cc:

Description

Normally, OSD items are hidden when entering the menu.

However, when used in the following way:

<osd name="foobar" .../>
<osd type="cmd_interface" command='osd_set_attr("foobar","enabled","condition?yes:no")' .../>

enabling the OSD item while the menu is active causes it to be displayed on top of the menu.

I figure the expected/desired behavior would be that nothing happens while in menu mode but that the OSD item would appear after leaving the menu.

Tested with r4696 on Android (CyanogenMod? 7.0.3). (Sorry, later releases crash on my phone, so I can't test newer ones.)

Change History (4)

comment:1 Changed 7 years ago by mvglasow (2)

Now tested with r5187 on a different device (also running Android), the issue is the same

comment:2 Changed 6 years ago by mvglasow (2)

See also #1073, there seems to be a general issue with some OSD items sometimes displaying on top of the menu.

comment:3 Changed 6 years ago by tryagain

A fix for the case when <osd type="button"> src attribute is changed by command interface is applied in r5283.

I did not found any other cases in the code where this bug can be triggered.

Feel free to reopen if I missed something, attaching your osd section of navit.xml.

tryagain

comment:4 Changed 6 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.