Opened 8 years ago

Closed 6 years ago

#1059 closed defect/bug (worksforme)

toggle_announcer OSD item not updated when clicked

Reported by: mvglasow (2) Owned by: cp15
Priority: major Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords: sound, osd
Cc:

Description

When clicking a toggle_announcer OSD item, the icon is not updated to reflect the current speech output state until the screen is redrawn (returning from menu, map moving etc.) There is no visual feedback to the user telling them that the click was registered.

Steps to reproduce:

  • Create OSD layout with toggle_announcer item.
  • Look at the icon (should be "speech on" icon on startup).
  • Click/tap/touch the control, and observe the icon. It stays the same.
  • Go to the menu and return, or drag the map around (or do anything that causes the screen to be redrawn). Observe the icon. It now reflects the correct state again.

Tested on Android 2.3 (CyanogenMod? 7.1.0 on Nexus S).

Note that this may be difficult to reproduce in a moving vehicle (or even a standing vehicle) as the GPS updates may cause screen redraws.

Change History (4)

comment:1 Changed 8 years ago by mvglasow (2)

Seems this is platform-specific, r5203 on Windows does not have this issue - here the icon updates instantly

comment:2 Changed 7 years ago by usul

  • Component changed from osd/core to port/android
  • Keywords sound osd added
  • Milestone set to version 0.5.1
  • Owner changed from Singesang to cp15

We need to check this on Android and other platforms.

Anyway, seems to be a very confusing bug, so scheduled for next hotfix.

comment:3 Changed 7 years ago by sleske

Linux apparently does not have this issue either. Tested with Linux and graphics plugin "gtk_drawing_area": The icon changes immediately when clicked.

Is this maybe a problem with the "android" graphics plugin?

comment:4 Changed 6 years ago by mvglasow (2)

  • Resolution set to worksforme
  • Severity set to normal
  • Status changed from new to closed

Tested again with r5910 on Android (which fixed another issue, #1261, related to toggle_anouncer). Here it works, so I'll close this ticket.

Note: See TracTickets for help on using tickets.