Opened 6 years ago

Last modified 5 years ago

#1087 reopened defect/bug

Too many spoken directions

Reported by: fred labrosse Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: normal Keywords: directions
Cc:

Description

For a while now I have experienced a really annoying bug: navit speaks too many directions of the "easy turn" type, on all small bends of the road. This does not happen everywhere but I have experienced that in the UK and in France.

Recently (recent svn checkout and OSM map), I have experienced that on the A487, just north of Aberystwyth in the UK, but also on the A44 west of Aberystwyth. This does not happen along the whole length of a given road, only on some sections.

The symptoms are very similar to the ones described in bug #1039 but this is on linux and I have removed all maps but the UK and France ones, to no avail.

What info do I need to provide?

Cheers,

Fred

Attachments (2)

tooManyDirections.png (107.1 KB) - added by fred labrosse 6 years ago.
An example I described in the text
tooManyDirections_r5334.png (91.8 KB) - added by fred labrosse 6 years ago.
Same as previous screenshot but with r5334

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by fred labrosse

An example I described in the text

comment:1 Changed 6 years ago by fred labrosse

Looking at the screen shot I just made (see attachment), there is a navigation event every time something merges onto the main road (where the route was planned), be it a road, a track, a footpath, etc.

comment:2 Changed 6 years ago by fred labrosse

I just discovered bug #171, where it is thought that the bug could be due to the road having a non 0 layer attribute (not sure why this should be an OSM bug and not a navit bug, but there you go).

I just checked, the road in the screenshot attached previously: it does not have a layer attribute set.

comment:3 Changed 6 years ago by tryagain

Hi!

If you have two map excerpts even of not visually overlapped regions, you might still have duplicate road items.

You may try to left only one map available to navit to test if that's your case.

Also, navigational consequences of overlapped maps should be gone since r5334, so switching to more recent build should solve your problem even with two maps active.

Please report, if that doesnt solve your issue.

tryagain.

comment:4 Changed 6 years ago by fred labrosse

Hi,

Thanks for answer. Removing the other map (France) did indeed solve the issue. I had r5313, so updated. Now running r5334:

# svn info
Path: .
Working Copy Root Path: /usr/portage/distfiles/svn-src/navit/navit
URL: http://navit.svn.sourceforge.net/svnroot/navit/trunk/navit
Repository Root: http://navit.svn.sourceforge.net/svnroot/navit
Repository UUID: ffa7fe5e-494d-0410-b361-a75ebd5db220
Revision: 5334
Node Kind: directory
Schedule: normal
Last Changed Author: mdankov
Last Changed Rev: 5334
Last Changed Date: 2013-01-01 13:01:47 +0000 (Tue, 01 Jan 2013)

I still have the problem, although with fewer of these too many directions (on the same example as the attached screenshot).

Fred

Changed 6 years ago by fred labrosse

Same as previous screenshot but with r5334

comment:5 Changed 6 years ago by tryagain

Hi!

Looks like you've made a change recently to A487.

Are you sure both used binary maps have same versions of these roads?

If road versions differ in speeds, acces flags and so on, they would be considered different roads and you'll get navigation instructions.

tryagain.

comment:6 Changed 6 years ago by fred labrosse

Yes, I have modified that road (I wanted to make sure there was nothing wrong on OSM about it (and then changed it a bit following a recent speed limit change).

One map us for France, the Other is UK. I guess there might be a bit of overlap between the two bounding boxes, but that road is in Wales, about 500 miles from France so should not be in the two maps.

I'll re-download maps, just in case.

Fred

comment:7 Changed 6 years ago by fred labrosse

So re-downloaded maps (a few hours apart) and the problem is gone.

I extract maps using planet extractor and the bounding boxes given by it for France and the UK and there is some overlap between the two maps. Even, some of Wales does overlap (the very southern tip), but the road in question is not in the overlapped region. The section I was giving as an example is not (far from), and as far as I can make it the whole road (A487) is outside the overlap (stops a few miles north of the overlap).

So I don't understand why this could have been a problem, but maybe people who know the code will make sense out of that.

Shall I close the bug?

Thanks.

Fred

comment:8 Changed 6 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed

This is known behavior to have some data outside of requested area.

Map excerpts are done at tile level, so if a tile overlaps with area you marked for download, you'll get that whole tile. See http://wiki.navit-project.org/index.php/Binfile#Extract_a_specific_area

comment:9 Changed 5 years ago by fred labrosse

  • Resolution fixed deleted
  • Severity set to normal
  • Status changed from closed to reopened

I recently did in upgrade from svn and downloaded at the same time maps from France and UK. The problem reappeared!

Reopening.

Note: See TracTickets for help on using tickets.