Opened 13 years ago

Closed 12 years ago

#109 closed defect/bug (worksforme)

Segmentation fault if compiled with -g

Reported by: niccolo@… Owned by: anonymous
Priority: major Milestone: version 0.1.0
Component: core Version: git master
Severity: Keywords: segfault CFLAGS
Cc:

Description

I tried to compile a today CVS snapshot, I want to make a Debian package, so I used some Debian files that worked well for version 0.0.4. Now I get a segmentation fault when Navit starts and opens an OpenStreetMap? binary file.

The problem disappear if I declare CFLAGS="-O2" option when invoking ./configure, the Debian makefile instead wish to run this:

./configure --host=i486-linux-gnu --build=i486-linux-gnu --prefix=/usr --mandir=${prefix}/share/man --infodir=${prefix}/share/info CFLAGS=

in this case configure will expand CFLAGS="-g -O2" causing the problem.

My environment is: Debian Lenny (Testing), gcc version 4.2.3 (Debian 4.2.3-2)

Change History (3)

comment:1 Changed 13 years ago by anonymous

  • Milestone set to version 0.1.0
  • Owner changed from somebody to anonymous
  • Status changed from new to assigned

comment:2 Changed 12 years ago by KaZeR

Does the problem still occurs with recent versions of navit? if no, please close the ticket. Otherwise, just bump it.

comment:3 Changed 12 years ago by KaZeR

  • Resolution set to worksforme
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.