Opened 7 years ago

Closed 7 years ago

#1090 closed defect/bug (fixed)

arrow icons missing / not displayed?

Reported by: ah be Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

hi I have a similar issue as reported on this thread http://trac.navit-project.org/ticket/498, though for the armv4t tar.gz version of navit (around 22.12.2012 downloaded).

as the arrows have been reported to cause problems on some platforms I tried different suggestions:

<osd enabled="yes" type="navigation_next_turn" x="320" y="30" w="160" h="60" background_color="#000000cc" icon_src="$NAVIT_SHAREDIR/xpm/%s_wh_8_8.png"/> <osd enabled="yes" type="navigation_next_turn" x="320" y="90" w="160" h="60" background_color="#000000cc" icon_src="$NAVIT_SHAREDIR/xpm/gui_%s_wh_48_48.png"/> <osd enabled="yes" type="navigation_next_turn" x="320" y="150" w="160" h="60" background_color="#000000cc" icon_src="$NAVIT_SHAREDIR/xpm/%s.png"/> <osd enabled="yes" type="navigation_next_turn" x="320" y="210" w="160" h="60" background_color="#000000cc" icon_src="$NAVIT_SHAREDIR/xpm/gui_%s.png"/>

but none of those did actually give anything other than the little yellow square with the questionmark in it.

as I tested this from my computer at home, navigation always started with some STRONG TURN, so it could be either the icon missing completetly or the path being wrong.

best regards and happy new year and many thanks to the navit team for the tremendous work (using navit since 4years for routing, and am very happy about it)

robin

Change History (5)

comment:1 Changed 7 years ago by tryagain

Hi!

It is working for me well on android build of svn 5328 with

<osd type="navigation_next_turn" x="0" y="-96" w="96" h="76" icon_src="%s_wh.png" osd_configuration="1"/>

There's no need to specify full path for the picture unless you put handmade version of it to some unusual posiiton like /sdcard/navit/icons or so.

Happy new year!

comment:2 Changed 7 years ago by ah be

I thought I had tried your setup as well, but I will give it another try.

I scanned through the icons in the xpm folder an looked for arrow in the name. Now I get something like

gui_arrow_down_16_16.png gui_arrow_down_32_32.png gui_arrow_down_48_48.png gui_arrow_down_8_8.png gui_arrow_down_96_96.png gui_arrow_down.png gui_arrow_down.svg gui_arrow_left_16_16.png gui_arrow_left_32_32.png gui_arrow_left_48_48.png gui_arrow_left_8_8.png gui_arrow_left_96_96.png gui_arrow_left.png gui_arrow_left.svg gui_arrow_right_16_16.png gui_arrow_right_32_32.png gui_arrow_right_48_48.png gui_arrow_right_8_8.png gui_arrow_right_96_96.png gui_arrow_right.png gui_arrow_right.svg gui_arrow_up_16_16.png gui_arrow_up_32_32.png gui_arrow_up_48_48.png gui_arrow_up_8_8.png gui_arrow_up_96_96.png gui_arrow_up.png gui_arrow_up.svg

so I was wondering where your '_wh.png' comes in when you write icon_src="%s_wh.png" as there is no wh.png in the filenames. or more generally speaking how is the arrow filename created within navit or what does the %s stand for exactly depending on directing command.

best regards and happy new year from germany as well

robin

comment:3 Changed 7 years ago by tryagain

Hi!

Did another try gave some success?

For navigational icons, you should have been looking for nav_*.png rather than for gui_*.png.

Also, navit currently considers _M_N suffixes, where M and N are digit sequences, to be image size markers and may strip them (if no image with given suffix exists) or add them as needed (if no suffix is given).

_wh and _bk variants of navigational images corresponds to white and black arrows.

Please point url of the exact binary package you're trying to work with so we can try to reproduce your problem.

tryagain

comment:4 Changed 7 years ago by ah be

hi,

I tried again: so apparently for the freerunner it also needs to be adjusted:

WORKS: <osd enabled="yes" type="navigation_next_turn" icon_src="$NAVIT_SHAREDIR/xpm/%s_wh_96_96.png"/> DOES NOT WORK: <osd enabled="no" type="navigation_next_turn"/>

thanks for your help!

robin

comment:5 Changed 7 years ago by ah be

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.