Opened 4 years ago

Closed 4 years ago

#1092 closed defect/bug (fixed)

Country search: Cannot find Spain with locale cs_CZ.UTF8

Reported by: thuryn1 Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: sebastian.leske@…

Description

I would like to search country. I have cs_CZ.UTF8 locale. I make a click on country flag in search screen and I would like to search Spain. To find this country, I need to put "Esp" in the input field to see Spain country. I can see country in the list with my locale (Španělsko), but to find the country, I need to put country name in spanish. The same for Germany (need to put "Deu" word to fing Germany).

Change History (5)

comment:1 Changed 4 years ago by sleske

  • Summary changed from Country search to Country search: Cannot find Spain with locale cs_CZ.UTF8

I can confirm this behaviour (Navit rev. 5334 on Linux).

I think the problem is simply that in the country search an un-accented character does not match an accented character in a country name. For example, the input "Spa" does not find "Španělsko", but input "Špa" works.

I'm not sure whether this accented <-> un-accented mapping is even implemented. I'll try to check if I have time.

In the meantime, just search using the right accented characters (the on-screen keyboard supports them, click on the "äöü" button to get accented characters).

comment:2 Changed 4 years ago by sleske

After checking the source: This feature is apparently not implemented. It works for town and street names if the map is of type "binfile" (i.e. the type that the map downloader supplies) - that is implemented inside the binfile map code (see the call to linguistics_expand_special() in binmap_search_get_item() in binfile/binfile.c).

The country search code should probably use linguistics_expand_special() too, but it does not do so at present.

comment:3 Changed 4 years ago by sleske

  • Cc sebastian.leske@… added

comment:4 Changed 4 years ago by tryagain

Fixed with r5740

comment:5 Changed 4 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.