Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1111 closed defect/bug (duplicate)

Flood of turn easily and route details length

Reported by: thouthi57 Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords: flood of turn easily
Cc:

Description

This is to re-open Ticket #1039 on that topic already related to "Turn easily.." and thus long list of route details. This is back on on my Galaxy S GGT-I9000 with latest SVN 0.5.0.5441 with latest Navit Planet Extractor e.g Europe-Western-France as of today April 21st I've some evidence that this is a map problem

1) Downloading a suggested map within the App for France: -- while prompted to download first map and going ahead... -- is 1.4GB in size instead of 2.4 from the Planet Extractor -- does not reproduce the speech flood

2) Downloading and using the map from the Planet Extractor -- declare this map in the XML -- clearly produces the issue, probably on each minor segment/vertex of a road

3) In ticket #1039 people play with the map location or XML: -- this has nothing to do with map location or XML but only, most probably again, with the date from which onwards the map has been generated

4) Maps downloaded by the APP or pushed on the device after Planet extraction: -- the 1.4 GB France map as example, what is the link/storage location and generation date?

Congratulations again for this awesome application which is Navit

Change History (5)

comment:1 Changed 4 years ago by tryagain

Hi!

Please make sure you really have only one map and it's connected only once.

Go to the main menu, then Settings, then Maps. You should see only one binfile map.

If you have two or more binfile maps, try disabling them (just click an item to switch on/off).

If you have tuned your navit.xml, make sure your new map is not activated twice, for example, with <maps data="/sdcard/navit/*.bin"/> (included in navit*.xml shipped with android builds) and <map data="/sdcard/navit/osm_bbox_xxxxxxx.bin"/> (which you may have added by hand).

Also, if you have two maps active, you'll get described behavior, see #1046.

tryagain

comment:2 Changed 4 years ago by thouthi57

Hello and thanks for the answer! -- during my trials only 1 map is in the Settings-Maps -- it does not matter here if you have 1 or 2 maps according to my experience -- there are no other maps on the device except those mentioned in the tuned XML:

<mapset enabled="yes">

<map enabled="yes" type="binfile" data="/sdcard/external_sd/navit/navitmap.bin"/> <map enabled="yes" type="binfile" data="/sdcard/external_sd/navit/navitmap_002.bin"/>

</mapset>

in my case -- I check these maps with "TOWN" and then "View on Map" to make sure that they correspond to the mapset -- by the way, I found out that they need to carry the name "navitmap" and "navitmap_002" but I'm not sure at this point

Cheers!

comment:3 Changed 4 years ago by thouthi57

Hi, again me. Finally I managed to make it work. Details are as follows: In my custom XML I had either 1 or 2 maps, labeled navitmap.bin and navitmap_002.bin. Even if there is strictly no other navit*.bin elsewhere on the device but only on the path specified, the issue occurs. I had an erroneous certainty that the maps were to be named navitmap.bin and, when there are 2 of them, navitmap_002.bin. That's how the Android version does it when you start from scratch. The only thing I did to make it work was renaming the maps to e.g. france.bin and germany .bin and declare it accordingly in my custom XML file. That helped immediately. No excessive details in the route now.

As a consequence we could now close the ticket?

Thanks again! Thomas alias Thouthi57

comment:4 Changed 4 years ago by tryagain

  • Resolution set to duplicate
  • Status changed from new to closed

As the problem seems to be related to having multiple maps enabled, I'm closing ticket as duplicate of #1046.

comment:5 Changed 4 years ago by chris

Hi! As described in the forum (http://forum.navit-project.org/viewtopic.php?f=9&t=411), I observed that when having multiple, overlapping maps activated, navigation is resulting in many "turn easily" instructions every few meters.

When just one map is activated, navigation instructions are as expected.

When using two, non overlapping maps, navigation instructions are also as expected.

Chris

How to reproduce:

2 overlapping maps activated (flooded with turn easily instructions)

  • Downloaded predefined Germany map from http://maps9.navit-project.org/, saved as ger.bin
  • Downloaded predefined Denmark map from http://maps9.navit-project.org/, saved as den.bin
  • include both *.bin in xml config
  • starting navit, both ger.bin and den.bin are activated in settings->maps
  • search in Actions->Towns for Germany->24103 Kiel->Moltkestraße and set as position (and deactivate vehicle)
  • search in Actions->Towns for Germany->24937 Flensburg->Friesische Straße and set as destination
  • click main menu->route->description. It shows more than 100 entries, most of them "turn easily ..."

just 1 map activated (expected behaviour)

  • click main menu->actions stop navigation
  • deactivate den.bin in menu->settings->maps
  • search in Actions->Towns for Germany->24103 Kiel->Moltkestraße and set as position
  • search in Actions->Towns for Germany->24937 Flensburg->Friesische Straße and set as destination
  • click main menu->route->description. It shows less than 20 entries, just a few real "turn easily ..."

2 non overlapping maps activated (expected behaviour)

  • Downloaded predefined Germany map from http://maps9.navit-project.org/, saved as ger.bin
  • Downloaded predefined Latvia map from http://maps9.navit-project.org/, saved as latvia.bin
  • include both *.bin in xml config
  • starting navit, both ger.bin and latvia.bin are activated in settings->maps
  • search in Actions->Towns for Germany->24103 Kiel->Moltkestraße and set as position (and deactivate vehicle)
  • search in Actions->Towns for Germany->24937 Flensburg->Friesische Straße and set as destination
  • click main menu->route->description. It shows less than 20 entries, just a few real "turn easily ..."
Note: See TracTickets for help on using tickets.