Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#114 closed defect/bug (worksforme)

ghost espeak processes piling up

Reported by: kiddo Owned by: KaZeR
Priority: critical Milestone: version 0.2.0
Component: core Version:
Severity: Keywords: performance memory speechd
Cc:

Description

when using this in the configuration file:

<speech type="cmdline" data="espeak -s 150 -v french '%s' &amp;" />

ghost processes of espeak will be created each time navit speaks. Those process eat up 250mb of ram over a 2 hour car trip.

This doesn't seem to be espeak's fault, because doing that command myself in a terminal does not create a leftover process.

Change History (6)

comment:1 Changed 12 years ago by KaZeR

  • Milestone set to version 0.1.0
  • Owner changed from somebody to KaZeR
  • Status changed from new to assigned

comment:2 in reply to: ↑ description Changed 12 years ago by anonymous

i have the same problem...

Replying to kiddo:

when using this in the configuration file:

<speech type="cmdline" data="espeak -s 150 -v french '%s' &amp;" />

ghost processes of espeak will be created each time navit speaks. Those process eat up 250mb of ram over a 2 hour car trip.

This doesn't seem to be espeak's fault, because doing that command myself in a terminal does not create a leftover process.

comment:3 Changed 12 years ago by anonymous

i avoid the problem by using speechd-dispatcher,

comment:4 Changed 12 years ago by Tinloaf

I know that I have had that problem earlier, too. Now today I wanted to see if I could find out what causes this, and I can't reproduce it anymore. I know that my espeak has been updated recently, espeak -h is now giving me:

eSpeak text-to-speech: 1.39 08.Sep.08

My guess is that this was an espeak-bug that has been fixed it the recent release. could you upgrade to latest espeak and tell us if the problem persists?

comment:5 Changed 11 years ago by Tinloaf

  • Resolution set to worksforme
  • Status changed from assigned to closed

Since noone disagreed, I think this works with the new espeak version.

comment:6 in reply to: ↑ description Changed 11 years ago by smt

<speech type="cmdline" data="espeak -s 150 -v french '%s' &amp;" />

i had similar problems when using this format (wich is that way in the wiki,and doesnt seem right) it works fine for me when i remove the &amp; at the end my line looks the following: <speech type="cmdline" data="espeak -s 150 -v de '%s' > aplay /dev/null" /> wich works good for me

Note: See TracTickets for help on using tickets.