Opened 4 years ago

Last modified 4 years ago

#1142 new defect/bug

No rendering of white label backgrounds

Reported by: usul Owned by: cp15
Priority: minor Milestone: version 0.5.1
Component: port/wince Version: git master
Severity: Keywords: labels, map, rendering
Cc:

Description

Hi, there is a strange bug, that I noticed since a few builds and that I confirm for SVN5543:
Usually Navit displays most important labels (city, suburbs, bus_stops, ...) with a white outline/hollow to make it readable even on black backgrounds. This is obviously realized with the circle colour:

<!-- layer "labels" -->
<itemgra item_types="town_label_2e3" order="9-">
        <circle color="#000000" radius="3" text_size="10"/>
</itemgra>

But the same style doesn't work on WinCE: No image "wince without white labels.jpg" attached to Ticket #1142 No image "linux with white labels.jpg" attached to Ticket #1142

Attachments (3)

wince without white labels-1.JPG (248.5 KB) - added by usul 4 years ago.
No white labels on WinCE
wince without white labels-2.JPG (216.1 KB) - added by usul 4 years ago.
No white labels on WinCE (next zoomlevel)
linux with white labels.png (20.9 KB) - added by usul 4 years ago.
white outline on linux

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by usul

No white labels on WinCE

Changed 4 years ago by usul

No white labels on WinCE (next zoomlevel)

Changed 4 years ago by usul

white outline on linux

comment:1 Changed 4 years ago by usul

Please compare: (see strange effects on Marienplatz label)

No white labels on WinCE No white labels on WinCE (next zoomlevel)

But on Linux we have white outlines: white outline on linux

comment:2 Changed 4 years ago by usul

  • Milestone set to version 0.5.1
  • Priority changed from major to minor
Note: See TracTickets for help on using tickets.