Opened 6 years ago

Closed 6 years ago

#1156 closed defect/bug (fixed)

Android Search for Address country Flag not updating

Reported by: kamikaaze Owned by: cp15
Priority: trivial Milestone: version 0.5.1
Component: port/android Version: git master
Severity: Keywords: i18n, menu, icon, language
Cc:

Description

After switching to another Country in the Android Search Activity, the country Image (Flag) for the selected Country will not be shown. It is visible after leaving and reentering the Search Activity.

The Patch submitted will fix this behaviour.

Attachments (1)

android_search_flag_image.patch (628 bytes) - added by kamikaaze 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by kamikaaze

comment:1 Changed 6 years ago by usul

  • Keywords i18n menu icon language added
  • Milestone set to version 0.5.1

comment:2 Changed 6 years ago by tryagain

It looks like I cant reproduce the bug on my HTC Wildfire S.

When I compile my apk, I do not supply any image scaling parameters, so defaults are used. It could be related to your non-default scaling parameters, if you use some.

It also can be related to actual screen resolution of the given device.

Can you please give more details how to reproduce the bug?

comment:3 Changed 6 years ago by tryagain

Hm, I was able to reproduce this after upgrading to current svn. Month old svn seems to be unaffected...

comment:4 Changed 6 years ago by tryagain

Hey, this seems to be build method dependednt. Autotools builds make country names like country_??_32_32.png while cmake ones produce country_??.png.

I don't like an idea to hardcode any sizes into the java code. We should fix our autotools build and then remove existing '+ "_32_32"' occurence from NavitAddressSearchActivity?.java.

tryagain

comment:5 Changed 6 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r5629

Note: See TracTickets for help on using tickets.