Opened 4 years ago

Closed 6 months ago

#1171 closed defect/bug (fixed)

*.bin filter doesn't work as expected

Reported by: usul Owned by: KaZeR
Priority: major Milestone: version 0.5.1
Component: core Version: git master
Severity: trivial Keywords: binfile, filename, xml
Cc: sebastian.leske@…

Description

To make my configuration comfortable, I use this line to add all binfiles in a directory:

<mapset enabled="yes">
	<map type="binfile" enabled="yes" data="$NAVIT_SHAREDIR/maps/*.bin"/>
</mapset>

This works of course, but it only adds the first matching binfile :( Furthermore just this line is displayed in the UI maplist, but not the dedicated binfiles it adds.

Steps to reproduce:

  • Compile navit
  • Download a new area as a seperated binfile in ./maps/ directory
  • Change navit.xml with the mentioned lines

Change History (6)

comment:1 Changed 4 years ago by sleske

Note that right now using more than one binfile will cause problems with navigation; see #1046. So right now adding all binfiles would probably not really help. Still, the present behavior is confusing.

The name in the maplist needs to be fixed, of course.

comment:2 Changed 4 years ago by sleske

  • Cc sebastian.leske@… added

comment:3 Changed 4 years ago by tryagain

Actually, we have the 'maps' tag for that, please try

<mapS type="binfile" enabled="yes" data="$NAVIT_SHAREDIR/maps/*.bin"/>

And yes, using multiple binfiles is not recommended for now ( see #1046)

tryagain

Last edited 4 years ago by usul (previous) (diff)

comment:4 Changed 4 years ago by usul

  • Severity set to trivial

comment:5 Changed 4 years ago by usul

Ok, so I would suggest we extend the default navit.xml with a example I also updated the wiki http://wiki.navit-project.org/index.php/Configuration#Maps_Options (and Full list of course).

Otherwise I think this ticket can be closed :)

comment:6 Changed 6 months ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to fixed
  • Status changed from new to closed

I will close this ticket now, it is really old and seems to be fixed, if the problem is still there please create a new ticket.

Jkoan

Note: See TracTickets for help on using tickets.