Opened 4 years ago

Last modified 2 years ago

#1189 reopened defect/bug

OSM emergency_access loaded as a street_service

Reported by: fred labrosse Owned by: cp15
Priority: major Milestone: version 0.5.1
Component: mapdrivers/OSM Version: git master
Severity: normal Keywords:
Cc:

Description

I recently travelled to France on the A26 coming from Calais going to Laon. The routing wanted me to exit the A26 on the street_service at http://www.openstreetmap.org/#map=18/49.57961/3.69736&layers=D which is in fact a road designed for emergency services to access the motorway and is locked and not normally usable by normal drivers. This is correctly marked as a emergency_access on OSM but translated as a street_service in navit and therefore used for the routing.

Change History (7)

comment:1 Changed 4 years ago by fred labrosse

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, for some reason I ended up submitting the same ticket twice. Marking this one as duplicate.

comment:2 Changed 4 years ago by fred labrosse

  • Resolution duplicate deleted
  • Status changed from closed to reopened

For some reason #1188 can't be viewed so reopening this one.

comment:3 Changed 4 years ago by sleske

The problem is that the Openstreetmap tag service=emergency_access is a bit ambiguous.

It is used for roads mainly meant or specifically designated for emergency vehicles.

However, that does not necessarily mean that the road is closed to other traffic. There are many roads with service=emergency_access which are also used as regular service roads, or as footpaths. See for example these roads in Germany: http://www.openstreetmap.org/way/112979129 , http://www.openstreetmap.org/way/149966612 which are designated access roads for emergency vehicles, but may be used by other delivery traffic, too.

So it might not be a good idea to never route over "service=emergency_access" roads, because they might be the only access to an area.

In a perfect world, roads exclusively reserved for emergency vehicles would be tagged acces=no or access=private (emergency vehicles are allowed everywhere anyway), but life is life... I'm not sure how to solve this.

comment:4 follow-up: Changed 4 years ago by fred labrosse

I see the point. Should access be made "official" rather than private? I'm not sure what navit would do.

I also see the pain of editing all of these...

comment:5 in reply to: ↑ 4 Changed 4 years ago by sleske

Replying to fred labrosse:

I see the point. Should access be made "official" rather than private? I'm not sure what navit would do.

I also see the pain of editing all of these...

It's certainly not a good idea to go editing OpenStreetMap? to help Navit - they don't take kindly to that. First we'd have to find out how the tag is used on OSM, and what it means. Then we can discuss how Navit should treat it while routing.

One idea would be to keep it routable, but with very low priority. That way Navit would use it if it's the only way to get somewhere (like when the only access street is tagged), but would not use it in situations like in this bug where it's just a shortcut.

comment:6 Changed 3 years ago by jandegr

I came across many more of such cases, Navit leaves or enters motorways over any service road it finds, also over those service access roads of fuelstations and parkings (aire's) along motorways. I started by adding gate, bollards and such in maptool and providing an icon for them, but then as a solution for the routing I took a shortcut by adding an AF_THROUGH_TRAFFIC_LIMIT flag to service road's in maptool and override the default value for through_traffic_penalty in navit.xml. As I already did somthing similar for AF_LINK in maptool (see #1279) it was simple to do so. It has worked very well so far, if you set a destination that is only accessible over a service road you get a normal route, otherwise the service road is avoided just the same as access=destination tagged roads.

comment:7 Changed 2 years ago by kazer

  • Milestone set to version 0.5.0
Note: See TracTickets for help on using tickets.