Opened 5 years ago

Closed 5 years ago

#1250 closed defect/bug (fixed)

spoken instruction "turn left error"

Reported by: jandegr Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: normal Keywords:
Cc:

Description

Hi On a parking lot the following spoken instructions can be heard when the starting point is on the parking lot : "go left error" and "go right error"

When the destination is on the parking lot the following can be heard in addition to the go left and right error : "You have reached your destination error" (0.5.0 5890)

a sample of such a parking lot : http://www.openstreetmap.org/#map=18/51.00140/5.70946

or another: http://www.openstreetmap.org/#map=17/49.52514/2.72364

regards, Jan

Attachments (1)

ParkingSpeech.diff (334 bytes) - added by jandegr 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by jandegr

Hi, With the following patch it announces properly but to set the announcement level from the xml file you have to explicitly add it to the <navigation><announce>section (type street_parking_lane)

regards, Jan

Last edited 5 years ago by jandegr (previous) (diff)

Changed 5 years ago by jandegr

comment:2 Changed 5 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed

Committed in r5897.

Thanks jandegr!

comment:3 Changed 5 years ago by jandegr

Hi kazer, Thanks for the commit and it makes error go away, but AFAIK you also have to change the navit.xml file as described above to announce as it should. Somewhere below the vehicleprofiles : change : <navigation> <announce type="street_0,street_1_city" level0="25" level1="100" level2="200" unit="m"/> into: <navigation> <announce type="street_0,street_1_city,street_parking_lane" level0="25" level1="100" level2="200" unit="m"/>

regards, jan

comment:4 follow-up: Changed 5 years ago by jandegr

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi, I reopen this ticket because I use it to illustrate a related issue, not because the original issue showed up again. seen : the work on #1269 and the ongoing work to give navigation.c a major overhaull I would like to draw some attention to line 1844 of navigation.c (sf r5970) In that line the decision is made to throw the spoken word "error" at the driver. It is confusing for the driver and of zero help to track the issue. IMHO this is a clear sample of where you want to log an error and provide a little info as well for in case someone wants to start debugging it.

Since there are already plenty of tickets, it seemed sensible to reopen one that is related and provides a use-case sample already.

The parking lot I refer to in the original topic is just a spot where I could make Navit reproduce it as many times as needed untill I found the source of the trouble. In real life driving it goes as :

  • driving a straight road and next maneuvre several kilometers away.
  • because of a drop in gps accuracy the 'place on road' helper now places the vehicle on a parkinglot adjacent to the road
  • promptly Navit starts speaking al kinds of instructions and to make sure the confusion is complete it inserts the word 'error' in just about every scentence.
Last edited 5 years ago by jandegr (previous) (diff)

comment:5 in reply to: ↑ 4 Changed 5 years ago by sleske

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to http://wiki.navit-project.org/index.php/user:jandegr:

I reopen this ticket because I use it to illustrate a related issue, not because the original issue showed up again. [...] Since there are already plenty of tickets, it seemed sensible to reopen one that is related and provides a use-case sample already.

Sorry, but no. It is very confusing if a ticket that is fixed is reopened for a new problem. The description no longer makes sense, and you have to read through all the comments to find out what the problem is. Do not do this.

Please open a new ticket. If you want to refer to the examples given here, just link to this ticket in the description of the new ticket, or simply repeat the example. Thank you!

Note: See TracTickets for help on using tickets.