Opened 5 years ago

Closed 4 years ago

#1252 closed defect/bug (fixed)

Android: cursor up/down swapped on external keyboard

Reported by: mvglasow (2) Owned by: cp15
Priority: major Milestone:
Component: port/android Version: git master
Severity: normal Keywords:
Cc: http://wiki.navit-project.org/index.php/user:mvglasow, (2)

Description

Steps to reproduce:

  • Start Navit on Android with an external (e.g. Bluetooth) keyboard connected
  • In Internal GUI, go to Town and type a few letters to get a list of towns
  • Try navigating through the list

You will see that the "cursor up" key moves the selection down and vice versa.

Tested on r5889, Cyanogenmod 11m9 (Android 4.4/KitKat) on a Nexus S, with a Samsung Bluetooth keyboard. The arrow keys behave correctly in other applications.

Change History (3)

comment:1 Changed 5 years ago by mvglasow (2)

  • Cc http://wiki.navit-project.org/index.php/user:mvglasow (2) added

comment:2 Changed 4 years ago by mvglasow (2)

I have since reproduced this behavior on Android both with a Bluetooth and a USB keyboard, on two different phones and using at least two different Android versions. On the other hand, Linux is not affected. Seems like an Android-specific bug.

comment:3 Changed 4 years ago by mvglasow (2)

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with merge request 30.

Note: See TracTickets for help on using tickets.