Opened 3 years ago

Closed 5 weeks ago

#1278 closed defect/bug (fixed)

Android GUI - Screen rotation takes back to main screen

Reported by: antonio pisano Owned by: cp15
Priority: major Milestone: version 0.5.1
Component: port/android Version:
Severity: normal Keywords: android rotation rotate screen gui
Cc:

Description

On Android, when going through menu, if screen is rotated GUI "resets", going instantly back to the main screen.

To reproduce: open navit keeping phone in vertical (shorter) position. Try selecting a POI for a random city. Notice you can't access the search tab in POIS screen. Rotate screen to horizontal (large) position to see and access search tab. Damn! You are back to main screen again!

This is a real show stopper in many use cases and severely afflicts user experience on android.

Version is latest from f-droid repositories: 0.5.0-5889

Change History (3)

comment:1 Changed 3 years ago by jandegr

Hi, I have seen that on android too. I did a quick test and it also happens on linux as soon as you resize the window, so it is more like a general problem instead of only Android related.

And now I realize it is probably related to #1149

Last edited 3 years ago by jandegr (previous) (diff)

comment:2 Changed 23 months ago by kazer

  • Milestone set to version 0.5.1

comment:3 Changed 5 weeks ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to fixed
  • Status changed from new to closed

Closeing this one because it #1149 reports the same behavior

Note: See TracTickets for help on using tickets.