Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1281 closed defect/bug (fixed)

Android navit-svn-5996.apk does not run on asus memopad

Reported by: jandegr Owned by: cp15
Priority: major Milestone:
Component: port/android Version: git master
Severity: normal Keywords:
Cc:

Description

navit-svn-5996.apk does not run on asus memopad android 4.2.2 As soon as the app. opens it closes again

Change History (6)

comment:1 Changed 5 years ago by jandegr

The youngest version I could get to run is 0.5.0 5988 self-built. I tried to build 5996 with ndk-9d instead of ndk-8 but did not work either. As stated above, navit-svn-5996.apk downloaded from http://download.navit-project.org/navit/android/svn/ does not work either.

But now it seems by removing my custom navit.xml, 5996 does run fine, are there any hints available on how to fix my navit.xml and why can navit.xml make it shut down ?

Last edited 5 years ago by jandegr (previous) (diff)

comment:2 Changed 5 years ago by tryagain

Hi!

Thank you for your report.

AFAIK, recent changes shouldn't make navit crash with config worked with previous version. Most probable commit that could break things is http://sourceforge.net/p/navit/code/5989/, which affects many osds. I pretty sure i have tested all osds, but there's probabilyty i have missed something.

Is there any suspicious logcat output? Can you share your customized navit.xml?

tryagain.

comment:3 Changed 5 years ago by sleske

Yes, first we'd need the log output from the Android logs. To get these:

  • If you have the Android SDK, you can grab the logs using "adb logcat".
  • Otherwise, you'll need to install an app that can read them. I have never done that, but https://code.google.com/p/android-logger/ looks like it should work.

Post the logs that you get (as an attachment, if they are long), then we'll see.

comment:4 Changed 5 years ago by jandegr

I just got home, so no logs yet, but if I disable the following one, my navit.xml works again (tested on 5989), so I'm confident the breaking one is found.

<osd enabled="yes" type="gps_status" x="20" y="206"  w="60" osd_configuration="1" />

And speedwarner lost the circle around it, or was that intentional ?

comment:5 Changed 5 years ago by tryagain

  • Resolution set to fixed
  • Status changed from new to closed

Intention was only to allow negative widths/heights to be used to set item size of "full screen minus something".

Fix should be applied in r5989.

Thank you for your report once again. Feel free to reopen if you still see some regressions.

tryagain.

comment:6 Changed 5 years ago by kazer

We are preparing a long-overdue update for android in the google play store.

To get the ball rolling, I have pushed a new version ( r6021 ) as Beta in the store.

You can join the brand new beta program by subscribing to this group : https://groups.google.com/forum/#!forum/navit-beta

Once we get enough user feedback about this build we can start updating the production release.

Note: See TracTickets for help on using tickets.