Opened 6 years ago

Closed 5 years ago

#1283 closed defect/bug (fixed)

graphics null

Reported by: andrea del monaco Owned by: KaZeR
Priority: critical Milestone:
Component: core Version: git master
Severity: normal Keywords:
Cc:

Description

Hi, i've compiled navit using this guide: http://wiki.navit-project.org/index.php/Raspberry_Pi

Rasp details: 3.18.7-v7+ Raspbian wheezy

The problem is that when i try to run it, i get those errors: pi@raspberrypi:/home/pi/navit-build/navit# ./navit Running from source directory error:navit:graphics_new:Failed to load graphics plugin gtk_drawing_area. error:vehicle_gpsd:vehicle_gpsd_try_open:gps_open failed for 'gpsd://localhost'. Retrying in 10 seconds. Have you started gpsd? error:navit:event_add_timeout:Can't find event system method add_timeout. Event system is not set. error:navit:navit_init:Warning: No graphics subsystem available. error:navit:event_main_loop_run:Can't find event system method main_loop_run. Event system is not set.

I've also seen this while compiling: No freetype library found, graphics modules may not be available

i've attached cmake and make output logs

Attachments (2)

Cmake_logs.log (12.3 KB) - added by andrea del monaco 6 years ago.
CMake command output
Make_logs.log (21.1 KB) - added by andrea del monaco 6 years ago.
Make command output file

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by andrea del monaco

CMake command output

Changed 6 years ago by andrea del monaco

Make command output file

comment:1 Changed 6 years ago by tryagain

Hi!

As you noticed, Cmake logs tell you that you may have no graphics because there's no libfreetype available, and that's what you actually get.

Did following code shown some errors to you?

sudo apt-get install subversion freeglut3-dev imagemagick libdbus-1-dev libdbus-glib-1-dev libdevil-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev libgarmin-dev libimlib2-dev libpq-dev libqtwebkit-dev librsvg2-bin libspeechd-dev libxml2-dev ttf-liberation

You may check if every package from that list is installed by issuing following command:

apt list --installed subversion freeglut3-dev imagemagick libdbus-1-dev libdbus-glib-1-dev libdevil-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev libgarmin-dev libimlib2-dev libpq-dev libqtwebkit-dev librsvg2-bin libspeechd-dev libxml2-dev ttf-liberation

Actually, i think some of above packages are not necessary, but you must have libfreetype6-dev to have graphics.

tryagain

Last edited 6 years ago by tryagain (previous) (diff)

comment:2 Changed 6 years ago by andrea del monaco

This is the output from the first command:

root@raspberrypi:/home/pi# sudo apt-get install subversion freeglut3-dev imagemagick libdbus-1-dev libdbus-glib-1-dev libdevil-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev libgarmin-dev libimlib2-dev libpq-dev libqtwebkit-dev librsvg2-bin libspeechd-dev libxml2-dev ttf-liberation Reading package lists... Done Building dependency tree Reading state information... Done freeglut3-dev is already the newest version. imagemagick is already the newest version. libdbus-1-dev is already the newest version. libdbus-glib-1-dev is already the newest version. libdevil-dev is already the newest version. libfontconfig1-dev is already the newest version. libfribidi-dev is already the newest version. libgarmin-dev is already the newest version. libimlib2-dev is already the newest version. libpq-dev is already the newest version. libqtwebkit-dev is already the newest version. librsvg2-bin is already the newest version. libspeechd-dev is already the newest version. libxml2-dev is already the newest version. subversion is already the newest version. ttf-liberation is already the newest version. libfreetype6-dev is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

while the second command doesnt give me a output because its invalid. Did a research on google in order to get the correct command: root@raspberrypi:/home/pi# dpkg --get-selections subversion freeglut3-dev imagemagick libdbus-1-dev libdbus-glib-1-dev libdevil-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev libgarmin-dev libimlib2-dev libpq-dev libqtwebkit-dev librsvg2-bin libspeechd-d subversion install freeglut3-dev:armhf install imagemagick install libdbus-1-dev install libdbus-glib-1-dev install libdevil-dev install libfontconfig1-dev install libfreetype6-dev install libfribidi-dev install libgarmin-dev install libimlib2-dev install libpq-dev install libqtwebkit-dev install librsvg2-bin install dpkg: no packages found matching libspeechd-d

Any suggestion?

comment:3 Changed 6 years ago by tryagain

Hmm, pretty much looks like cmake with freetype compatibility issue.

We use standard cmake module FindFreetype?.cmake (in my ubuntu, it's located at /usr/share/cmake-2.8/Modules/), it's called when we call find_package(Freetype) in our CmakeLists?.txt.

If it does not get detected with default settings, probably setting environment variable FREETYPE_DIR to /usr before a clean cmake run would solve your problem. Most probably cmake in raspbian wheezy is outdated.

tryagain.

comment:4 Changed 6 years ago by andrea del monaco

Hello,

thanks for your help.

I've fixed it following this guide: http://choorucode.com/2015/02/13/ogre-build-error-freetype-package-could-not-be-located/

Setting FREETYPE_INCLUDE_DIR_freetype2 /usr/include/freetype2/ and FREETYPE_INCLUDE_DIR_ft2build /usr/include/freetype2/

Hope this will help other users. I can post it in the forum if you want

comment:5 Changed 6 years ago by tryagain

It would be nice if you update this wiki page. Please specify your Raspbian version, cmake and freetype versions, and mark it as a workaround.

It might also be a good idea to try a simple cmake project to reproduce this behaviour, and file a bug to raspbian if it does not find freetype.

For example, put following CMakeLists.txt into an empty directory. Then run cmake . from that directory. It should report Freetype package being found.

cmake_minimum_required(VERSION 2.8)
find_package(Freetype REQUIRED)

comment:6 Changed 6 years ago by andrea del monaco

I will whem somebody will activate my account. Can you tell them to do it asap please?

comment:7 Changed 6 years ago by kazer

Account activated. For some reason I did not receive the latest account creation requests. Sorry about that!

comment:8 Changed 5 years ago by kazer

  • Resolution set to fixed
  • Status changed from new to closed

We now also provide an automated way to install Navit on raspbian : https://github.com/navit-gps/raspbian-ua-netinst

Note: See TracTickets for help on using tickets.