Opened 3 years ago

Closed 3 years ago

#1304 closed defect/bug (fixed)

Turns on minor road networks are not announced

Reported by: tryagain Owned by: jandegr
Priority: major Milestone: version 0.5.1
Component: navigation/highfive Version: git master
Severity: normal Keywords:
Cc:

Description

When I drive on a road mesh consisting of street_service and/or living_street, I have only announces like "follow the road for next XXX meters". Not a word is spoken about turn direction.

For example, route from a point at http://www.openstreetmap.org/way/33350972 to a point at http://www.openstreetmap.org/way/156353049

Looks like this issue arises always when you navigate from the minor (service, living_street) road. Regardless of destination road type, there's no direction info given.

Change History (3)

comment:1 Changed 3 years ago by jandegr

https://github.com/navit-gps/navit/commit/eb56ef30502ce819c1aeba4e84aa06e6032109ab

The exact distances can be subject for further discussion, but I think the reason why there were no announcements is found.

As far as I could verify, pre-H5 navit did not have those entries either, so this would be long-standing issue and not a regression.

comment:2 Changed 3 years ago by jandegr

already merged in the navit github repo https://github.com/navit-gps/navit/commit/c3beba5e727fc1882cc8b2a2c467cdbf245258c6

and since github seems to replace the sourceforge repo, I suppose this ticket can be closed

comment:3 Changed 3 years ago by jandegr

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.