Opened 4 years ago

Closed 4 years ago

#1340 closed defect/bug (fixed)

Ensure that the CSV plugin does not throw useless errors

Reported by: kazer Owned by: KaZeR
Priority: major Milestone: version 0.5.1
Component: core Version: git master
Severity: normal Keywords:
Cc:

Description

We've got report of erroneous errors thrown by the csv plugin

error: navit: attr_data_size: size for item_type unknown

Full discussion here : https://forum.navit-project.org/viewtopic.php?f=12&t=592

We should write some tests for the CI workflow, and ensure that we don't throw useless errors.

Change History (2)

comment:1 Changed 4 years ago by sleske

After digging into the code: The error message is indeed harmless in this case, but it is caused by problematic code. It occurs when the (internal) attribute list of the CSV map is copied (attr_dup_content in attr.c).

The copying code looks dodgy, I'll try to clean it up. Then the error will go away.

comment:2 Changed 4 years ago by sleske

  • Resolution set to fixed
  • Status changed from new to closed

A lot of the generic attribute handling code in attr.c is problematic, because most functions seem to support only some attributes (and different attributes in different functions). Anyway, attr_dup_content now supports attr_item_type, which prevents the error message.

Fixed in 914c18f .

Note: See TracTickets for help on using tickets.