Opened 18 months ago

Closed 3 months ago

#1345 closed defect/bug (fixed)

Crash on android

Reported by: kazer Owned by: cp15
Priority: major Milestone:
Component: port/android Version:
Severity: normal Keywords:
Cc:

Description

Reported by user tim01234 on IRC.

Last known working version for him : 089c9ea

E/AndroidRuntime( 1631): FATAL EXCEPTION: main
E/AndroidRuntime( 1631): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.navitproject.navit/org.navitproject.navit.Navit}: android.content.res.Resources$NotFoundException: Resource ID #0x0
E/AndroidRuntime( 1631):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2079)
E/AndroidRuntime( 1631):        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2104)
E/AndroidRuntime( 1631):        at android.app.ActivityThread.access$600(ActivityThread.java:132)
E/AndroidRuntime( 1631):        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1157)
E/AndroidRuntime( 1631):        at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 1631):        at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime( 1631):        at android.app.ActivityThread.main(ActivityThread.java:4575)
E/AndroidRuntime( 1631):        at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 1631):        at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime( 1631):        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:789)
E/AndroidRuntime( 1631):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:556)
E/AndroidRuntime( 1631):        at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime( 1631): Caused by: android.content.res.Resources$NotFoundException: Resource ID #0x0
E/AndroidRuntime( 1631):        at android.content.res.Resources.getValue(Resources.java:1049)
E/AndroidRuntime( 1631):        at android.content.res.Resources.getDimensionPixelSize(Resources.java:606)
E/AndroidRuntime( 1631):        at org.navitproject.navit.Navit.onCreate(Navit.java:320)
E/AndroidRuntime( 1631):        at android.app.Activity.performCreate(Activity.java:4465)
E/AndroidRuntime( 1631):        at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1049)
E/AndroidRuntime( 1631):        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2033)
E/AndroidRuntime( 1631):        ... 11 more

Change History (1)

comment:1 Changed 3 months ago by wiki.navit-project.org/index.php/user:tryagain

  • Resolution set to fixed
  • Status changed from new to closed

This one (a call to android.content.res.Resources.getDimensionPixelSize with zero resource id) should have been fixed with https://github.com/navit-gps/navit/commit/18faa2b387f688438b54de2398ddddba42f5b968

Note: See TracTickets for help on using tickets.