Opened 6 weeks ago

Closed 3 weeks ago

#1356 closed defect/bug (fixed)

android-arm crashes at startup

Reported by: kazer Owned by: http://wiki.navit-project.org/index.php/user:jkoan
Priority: blocker Milestone: version 0.5.1
Component: port/android Version: git master
Severity: normal Keywords:
Cc:

Description (last modified by kazer)

Tested on Galaxy S5 (android 4.4.4) via the device farm.

E Navit   : **1**A android.intent.action.MAIN
E Navit   : **1**D null
E NavitTextTranslations: initializing translated text ...
E NavitTextTranslations: ... ready
D AndroidRuntime: Shutting down VM
W dalvikvm: threadid=1: thread exiting with uncaught exception (group=0x41916da0)
E ACRA    : ACRA caught a RuntimeException for org.navitproject.navit
E ACRA    : java.lang.RuntimeException: Unable to start activity ComponentInfo{org.navitproject.navit/org.navitproject.navit.Navit}: java.lang.IllegalArgumentException: contentView required: pkg=org.navitproject.navit id=2131034112 notification=Notification(pri=0 icon=7f020005 contentView=null vibrate=null sound=null defaults=0x0 flags=0x0 when=1509918078206 ledARGB=0x0 contentIntent=N deleteIntent=N contentTitle=N contentText=N originalPackageName=N originalUserId=0 tickerText=13 kind=[null])
E ACRA    :      at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2523)
E ACRA    :      at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2582)
E ACRA    :      at android.app.ActivityThread.access$900(ActivityThread.java:174)
E ACRA    :      at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1321)
E ACRA    :      at android.os.Handler.dispatchMessage(Handler.java:102)
E ACRA    :      at android.os.Looper.loop(Looper.java:146)
E ACRA    :      at android.app.ActivityThread.main(ActivityThread.java:5731)
E ACRA    :      at java.lang.reflect.Method.invokeNative(Native Method)
E ACRA    :      at java.lang.reflect.Method.invoke(Method.java:515)
E ACRA    :      at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1291)
E ACRA    :      at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1107)
E ACRA    :      at dalvik.system.NativeStart.main(Native Method)
E ACRA    : Caused by: java.lang.IllegalArgumentException: contentView required: pkg=org.navitproject.navit id=2131034112 notification=Notification(pri=0 icon=7f020005 contentView=null vibrate=null sound=null defaults=0x0 flags=0x0 when=1509918078206 ledARGB=0x0 contentIntent=N deleteIntent=N contentTitle=N contentText=N originalPackageName=N originalUserId=0 tickerText=13 kind=[null])
E ACRA    :      at android.os.Parcel.readException(Parcel.java:1476)
E ACRA    :      at android.os.Parcel.readException(Parcel.java:1426)
E ACRA    :      at android.app.INotificationManager$Stub$Proxy.enqueueNotificationWithTag(INotificationManager.java:347)
E ACRA    :      at android.app.NotificationManager.notify(NotificationManager.java:152)
E ACRA    :      at android.app.NotificationManager.notify(NotificationManager.java:116)
E ACRA    :      at org.navitproject.navit.Navit.onCreate(Navit.java:301)
E ACRA    :      at android.app.Activity.performCreate(Activity.java:5580)
E ACRA    :      at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1093)
E ACRA    :      at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2487)
E ACRA    :      ... 11 more

Attachments (3)

navit-81b6055df58c290981e579c80ffa999c149319ab-arm-debug.apk (3.4 MB) - added by kazer 6 weeks ago.
81b6055df58c290981e579c80ffa999c149319ab from the CI
navit-81b6055df58c290981e579c80ffa999c149319ab-arm-debug.2.apk (3.3 MB) - added by kazer 6 weeks ago.
81b6055df58c290981e579c80ffa999c149319ab from local build
1f7be04a-236f-436f-adc1-c950238a2fa5.logcat (888.2 KB) - added by kazer 6 weeks ago.
logcat

Change History (10)

comment:1 Changed 6 weeks ago by kazer

Trying to find the culprit. Will update this comment.

* a1671c7f85bba03f4ab510c325123bf267273315 (current trunk/HEAD) : crashes
* 7004ae68f90c49f82d24dbff4dab5b14419317fa 
* d4f5b98c2232f2c9afb425d801f3af9f7b8d1f17 
* 4ec2d8e8c22a873cc995ef5890d7c3ea7c7dae0c 
* 74eb1f6152754eab0037fe8e3983e21981ad6c06 
* 546ea2ea152a28e5f243667036cc0dee1128ee56 
* 8161c11156bc24efae4814f3e4980e8b10f2bb9b 
* 19802a716ed5dc1f16a712a4924d2c04e96afd32 
* 4cf3f57d92ff17bf30e66f3340c2a6ce0ee57d2a : #3829 : crashes
* c96a84eba71b08957b93f3ac2a718a6746e852e7 : #3808 : crashes
* 6ca8b5763ac672c9c4fc8bc54647a773c39d3648 
* 6c7b30b74ad9da9efbf7b65276447bb407a8ba56 : #3788 : crashes
* 0b6027ff53acb558c2b200a1b3b8874f8259843a : #3931 : crashes 
* bd3e8e965236d9b2e25231518f864c32a3d74674 
* 0621e4d79f5d89518d451969cc6b4b280ff0ab79 
* 2b6c039494b54c4ef88f69e2b89388a1050912e3 : #3773 : works
* 3b5c8b8ac5f26b8c8a38a26f80b7ffa344d85d93 : #3756 : works
* 9de44afdd8c77ce668adea1c6ccb0340b51f73ef : #3750 : works
* 1a49c5775e7a81fec5e9b5cfbd68b9a065b3e674 : #3932 : crashes (but is a rebuild, original build failed)
* b1cbc462186edd6343e3601856409d40b025b677 : #3728 : works
* 81b6055df58c290981e579c80ffa999c149319ab : #3694 : works
Last edited 6 weeks ago by kazer (previous) (diff)

comment:2 Changed 6 weeks ago by kazer

  • Description modified (diff)

comment:3 Changed 6 weeks ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Owner changed from cp15 to http://wiki.navit-project.org/index.php/user:jkoan
  • Status changed from new to assigned

comment:4 Changed 6 weeks ago by kazer

As indicated by the crash of 1a49c5775e7a81fec5e9b5cfbd68b9a065b3e674 I believe that the issue is with the build system itself and not the code.

81b6055df58c290981e579c80ffa999c149319ab from the CI, build #3694 works.

81b6055df58c290981e579c80ffa999c149319ab rebuild locally crashes.

The rebuild was done by spinning up a local docker image, installing the android build using bash ci/setup_common_requirements.sh and then bash ci/setup_android.sh and building via git checkout 81b6055df58c290981e579c80ffa999c149319ab and running the android build.

Changed 6 weeks ago by kazer

81b6055df58c290981e579c80ffa999c149319ab from the CI

Changed 6 weeks ago by kazer

81b6055df58c290981e579c80ffa999c149319ab from local build

comment:5 Changed 6 weeks ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Milestone set to version 0.5.1
  • Priority changed from major to blocker

Set to blocker for 0.5.1 because we need working apk generation.

Changed 6 weeks ago by kazer

logcat

comment:6 Changed 6 weeks ago by kazer

  • Description modified (diff)

comment:7 Changed 3 weeks ago by http://wiki.navit-project.org/index.php/user:jkoan

  • Resolution set to fixed
  • Status changed from assigned to closed

The bug from the the logcat is now fixed, but it was not related to our build system.

Fixed by: https://github.com/navit-gps/navit/pull/374

Note: See TracTickets for help on using tickets.