Opened 12 years ago

Closed 11 years ago

#147 closed defect/bug (fixed)

routing needs improvement

Reported by: udo Owned by: somebody
Priority: major Milestone: version 0.2.0
Component: core Version:
Severity: Keywords:
Cc:

Description

When entering my home town navit routed to my home via the biggest road, then nearest smaller road and then the smallest road (my street). Instead Navit should at least have considered taking a short cut off the biggest road via a sideroad then another street onto the corner where I live. (need to show map to make more understandable) This is the shortest route I use every day. I.e.: logic needs to be checked. Also the 'wrong' route remained on the map, even though I did use the other shorter route; navit did not redraw or change map. (gtk issue?)

Change History (5)

comment:1 Changed 12 years ago by udo

Version is svn 0.1.0 from 8 june 2008

comment:2 Changed 12 years ago by anonymous

Hi, i've been reading your post yesterday and agreed totally to that routing issue. By today, i just tried to tweak my navit.xml file (edited the speeds for different streets, to use it with bike and car) and there i saw what most prolly the problem is: many, many little streets, where actually speed of like 50 km/h (sometimes 30) is allowed, are categorized as "street1city" (right click on the street in navit). in navit.xml, those streets (labelled "street_1_city" there) are set to a speed of 10:

<speed type="street_0,street_1_city" value="10" /> (in <route> section)

as far as i experienced, navit tries to find the most "rapid" (is this the right word?) instead of the shortest route. As the speed on this streets is limited to 10, navit prolly won't use this, but redirects you over bigger streets, which sometimes will give you distances thrice as long and more.

just edit the navit.xml file to proper speeds(hopefully those which are allowed in your country ;) ), which could look as this example:

<speed type="street_0" value="10" /> <speed type="street_1_city" value="40" />

to be honest, i didnt find any street in navit which is labelled "street0city", but maybe those are the "streetservice", which most time are located on parking lots.

i'm using openstreetmaps, converted with osm2navit, with the nearly most recent svn version.

maybe this issue could be fixed by default in future navit.xml files?

for further info's or question, i'm on IRC named as "tschaka" (if not, i'll be soon :P )

yours

comment:3 Changed 12 years ago by anonymous

addition: i've never found any "land" street yet, so i guess those "street_x_land" and "highway_land" values are useless yet. also, i am using rather recent OSM maps (not older then 4 days by now)

comment:4 Changed 12 years ago by KaZeR

  • Milestone set to version 0.1.0

Indeed, navit tries to route using the quickest route, not the shortest. Even if the shortest route could be useful for example when on foot or bike. Does the xml editing trick fits your needs?

comment:5 Changed 11 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from new to closed

I guess the new vehicleprofiles will do the trick.

Note: See TracTickets for help on using tickets.