Opened 10 years ago

Closed 7 years ago

#17 closed enhancement/feature request (fixed)

ignore gps updates when under a given speed threshold

Reported by: KaZeR Owned by: somebody
Priority: major Milestone: version 0.2.0
Component: core Version: git master
Severity: Keywords:
Cc: Patmulchrone, SLAM-ER

Description

With most gps unit, if you are stopped, the gps issues incorrect bearing which make the map to jump if you have set auto-centering. It could be avoided by ignoring gps updates when speed is like <5km/h

Attachments (1)

navit.c.patch (444 bytes) - added by Patmulchrone 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by KaZeR

  • Milestone set to version 0.1.0

comment:2 Changed 10 years ago by singesang

In addition, it should be updated again when the last shown position and the last reported position differ to much

comment:3 Changed 9 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in revision 1769.

comment:4 Changed 9 years ago by Ernia

  • Resolution fixed deleted
  • Status changed from closed to reopened

this issue seems to be still presente in navit-svn-2032 for n770/n800/n810. navit's deb is http://download.navit-project.org/navit/n800/svn/navit-svn-2032.deb, device is a n810, my navit.xml is here: http://pastebin.com/m48e1d73a let me know if i'm supposed to give you more elements. thanks a lot

comment:5 Changed 9 years ago by Ernia

  • Version set to svn

comment:6 Changed 9 years ago by Tinloaf

In revision 2091 we added a cumulative displacement filter, which should filter these updates out. Could you please update to at least 2091 and tell us if the problem persists? Thanks.

comment:7 Changed 9 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from reopened to closed

Since we didn't get a response here, and other users confirmed it works, I assume this is fixed with revision 2091.

Changed 8 years ago by Patmulchrone

comment:8 Changed 8 years ago by Patmulchrone

  • Cc Patmulchrone added
  • Resolution fixed deleted
  • Status changed from closed to reopened

I still experienced this bug on an n810. I have added a patch to use the direction from the cdf to redisplay the map. The compass still jumps all over the place when sitting still.

comment:9 Changed 8 years ago by SLAM-ER

  • Cc SLAM-ER added

This bug is still present for the n810 as of svn2310, at least in the case of weak GPS signals. The map does not rotate as long as the speed is 0km. However when the GPS readings are weak the position data might jump around from place to place causing Navit to start redrawing the map.

comment:10 Changed 7 years ago by akashihi

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r3445

The r3445 added ability to specify per-vehicleprofile speed/distance thresholds for static position detection.

Note: See TracTickets for help on using tickets.