Opened 11 years ago

Closed 10 years ago

#194 closed enhancement/feature request (wontfix)

Automatically disable screensaver

Reported by: avantman42 Owned by: KaZeR
Priority: minor Milestone: version 0.2.0
Component: core Version: git master
Severity: Keywords:
Cc:

Description

When running on a laptop (I run Navit on an EeePC) it would be useful if Navit could automatically disable the screen saver on start.

Change History (2)

comment:1 Changed 11 years ago by KaZeR

  • Milestone set to version 0.1.0
  • Owner changed from somebody to KaZeR
  • Status changed from new to assigned

comment:2 Changed 10 years ago by KaZeR

  • Resolution set to wontfix
  • Status changed from assigned to closed

The problem is that it greatly depends of your desktop environnement, your distro, your platform, etc.. For now, advised solution is to use a wrapper script:

#!/bin/sh
<do something to disable screen saver>
navit
<do something to enable screen saver>

Alternatively, you can also request the display when needed on some devices. For example, on a FSO-based distro on the FreeRunner?, you can use

  dbus-send --system --type=method_call --dest=org.shr.ophonekitd.Usage /org/shr/ophonekitd/Usage org.shr.ophonekitd.Usage.RequestResource string:Display
  < actually speak or do whatever needed >
 dbus-send --system --type=method_call --dest=org.shr.ophonekitd.Usage /org/shr/ophonekitd/Usage org.shr.ophonekitd.Usage.ReleaseResource string:Display

As a script for the speech command. This will unblank the screen, process the voice synthesis or whatever needed, then allow the screen to blank according to your device's settings.

Note: See TracTickets for help on using tickets.