Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#207 closed defect/bug (worksforme)

make install fails

Reported by: SlowRider <geeemmixx ath gmx doth net> Owned by: KaZeR
Priority: major Milestone:
Component: install Version: git master
Severity: Keywords:
Cc:

Description

Using the latest svn source, make install fails. I did:

svn up

./autogen.sh && ./configure --prefix=/home/ce/navit.app --disable-garmin --disable-samplemap --disable-hildon && make

make install

I logged the output of make install into a log file which is attached. The problems seem to start in line 622 where nonexistent svg files shall be converted to png.

Due to my lack of build systems I cannot fix it right away, sorry.

Attachments (1)

makeinstall.txt (85.5 KB) - added by SlowRider 12 years ago.
output of make install

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by SlowRider

output of make install

comment:1 Changed 12 years ago by SlowRider <geeemmixx@…>

Just for the records: I managed to workaround the make install problems by using --disable-svg2png. I have no clue though what the problem with svg conversion is, as ksvgtopng is installed. I guess I'm missing something else. It would be cool to sort this out, as I'd prefer adding new icons as plain svg rather than xpm.

comment:2 Changed 12 years ago by KaZeR

  • Resolution set to worksforme
  • Status changed from new to closed

I was unable to reproduce your problem, so i believe it comes from your setup. If it still occurs after a fresh checkout in a new dir, please reopen the ticket. Thanks.

comment:3 Changed 11 years ago by SlowRider

While I accept that we both do not have the resources to check the issue in-depth, I still guess that other people will fall into this trap jsut like me. For now it's ok to close the issue, but IMO it's worth reminding that the issue goes away when using -disable-svg2png.

Note: See TracTickets for help on using tickets.