Opened 10 years ago

Closed 10 years ago

#23 closed defect/bug (worksforme)

Error in Configure on Debian system with lCEGUIOpenGLRenderer

Reported by: StevenLeRoux Owned by: KaZeR
Priority: major Milestone: version 0.0.4
Component: install Version: 0.0.3
Severity: Keywords: debian configure cegui openglrenderer
Cc:

Description

checking for main in -lCEGUIBase... yes checking for init in -lCEGUIOpenGLRenderer... no Error! Something is wrong with CEGUIOpenGLRenderer. Do you have at least cegui-0.5?

Running Debian Sid

x1:# dpkg -l | grep cegui
ii  libcegui-mk2-1        0.5.0-2        Crazy Eddie's GUI
ii  libcegui-mk2-dev      0.5.0-2        Crazy Eddie's GUI

I tried with a fresh compil of CEGUI, but same result.

Change History (4)

comment:1 Changed 10 years ago by anonymous

  • Component changed from core to sdl
  • Owner changed from somebody to KaZeR

comment:2 Changed 10 years ago by KaZeR

  • Component changed from sdl to install
  • Milestone set to version 0.0.3
  • Status changed from new to assigned

The problem is that AC_CHECK_LIB(CEGUIOpenGLRenderer, main) fails

Probably because CEGUIOpenGLRenderer is linked against another library :

00008100 V _ZTVN5CEGUI13OpenGLTextureE 00008020 V _ZTVN5CEGUI14OpenGLRendererE 00008148 V _ZTVN5CEGUI17RendererExceptionE 00008160 V _ZTVN5CEGUI7TextureE 000080c0 V _ZTVN5CEGUI9EventArgsE 000080a8 V _ZTVSt12out_of_range 00008448 A bss_start

w cxa_finalize w gmon_start

00008448 A _edata 00008518 A _end 00006ff4 T _fini 00003688 T _init

At worst, we could remove this check. But it's useful to check if the user isn't using CEGUI-0.4 But CHECK_LIB isn't maybe the best suited check here.

comment:3 Changed 10 years ago by anonymous

  • Milestone version 0.0.3 deleted

Is this ticket still valid? Nobody else reported it, and we were unable to reproduce it.

comment:4 Changed 10 years ago by KaZeR

  • Milestone set to version 0.0.4
  • Resolution set to worksforme
  • Status changed from assigned to closed

Should be fixed in cvs, was due to a debug exit leftover. I'll tag as 'works for me' for now.

Note: See TracTickets for help on using tickets.