Opened 11 years ago

Closed 10 years ago

#236 closed defect/bug (worksforme)

Crash on N810 when using binfile with contour lines

Reported by: SlowRider Owned by: cp15
Priority: major Milestone:
Component: mapdrivers/OSM Version: git master
Severity: Keywords:
Cc:

Description (last modified by SlowRider)

I used srtm2osm (see wiki.openstreetmap.org) to create contour lines as an osm file. Then I converted this file to a navit bin file using osm2navit. The commands used read as follows:

mono srtm2osm/bin/Srtm2Osm.exe -bounds1 48.2 7.9 48.8 8.5 -large -step 25 -cat 100 50 -o Srtm.osm

cat Srtm.osm | osm2navit Srtm.bin

scp Srtm.bin user@tablet:/media/mmc2/MapsNavit/

I included both my usual map and this new file in navit.xml. On the desktop, everything works fine (see the attached screenshot, which is for your watching pleasure :) . On the N810 tablet, Navit tends to crash some time after startup, while zooming and panning the map. Panning or zooming only does not crash Navit, so it seems to be the combination of both: Zoom out three times, pan three times, crash.

The error message I get reads as follows: navit[3352]: GLIB ERROR default - file binfile.c: line 100 (lfh_to_cpu): assertion failed: (lfh != NULL) aborting... Aborted

I try to attach the osm and the bin file. I'm pretty aware of the fact that it will be difficult (if not impossible) to reproduce or even fix the problem.

Here are the files:

http://christeck.de/stuff/navit_srtm_crash.tar.gz

Attachments (1)

NavitWithContourLines.png (249.7 KB) - added by SlowRider 11 years ago.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by SlowRider

comment:1 Changed 11 years ago by SlowRider

  • Description modified (diff)

comment:2 Changed 11 years ago by kazer

Sorry for being so silent about your issue for so long. Is the ticket still valid?

comment:3 Changed 10 years ago by kazer

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.