Opened 12 years ago

Closed 12 years ago

#255 closed defect/bug (fixed)

gpx files 0 byte or 'empty'

Reported by: Udo Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

I power on the ipaq H2210 I wait for the GPS to obtain a fix (blinking led on the CF Holux) I fire up navit After doing some walking this way I find a few 0 byte gpx files and a few files with all the xml headers except position lines. What could be causing this?

Change History (4)

comment:1 Changed 12 years ago by Udo

<vehicle name="udo" enabled="yes" active="1" update="1" follow="4" source="file://dev/ttyS4" color="#0000ff" color2="#ff0000"> <log type="gpx" data="track_%Y%m%d%i.gpx" flush_size="1048576" flush_time="900" /> </vehicle>

comment:2 Changed 12 years ago by Udo

cat track_200808284.gpx

<?xml version="1.0" encoding="UTF-8"?> <gpx version="1.0" creator="Navit http://navit.sourceforge.net" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.topografix.com/GPX/1/0" xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd"> <trk> <trkseg> </trkseg> </trk> </gpx>

comment:3 Changed 12 years ago by Ssinger

Fixed in svn 1604.

vehicle_add_attr was not being called from the xmlconfig. This meant that the logging callback was never registered against the vehicle. So no logging of data ever took place.

Someone please mark this bug as fixed.

comment:4 Changed 12 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.