Opened 12 years ago

Closed 11 years ago

#276 closed defect/bug (fixed)

Navit City search does not work

Reported by: Lollisoft Owned by: KaZeR
Priority: major Milestone: version 0.2.0
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Hi,

I know there was a working city search last time I used navit on my FreeRunner?. Today I installed svn-1959 and I can't search.

As a symptom I suppose to be a reason is, all the letters entered are capital. As it has worked there was only the first one capital. Is the search case sensitive ?

Also the keyboard is still not fully viewable in vertical display mode. But I'll see in trac if there is a solution to use for.

Thanks

Lothar

Attachments (1)

navit_town_intl.diff (1.3 KB) - added by Flohack 12 years ago.
Patch to add a Town (Intl.) button

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Lollisoft

Ticket #277 is related to this ticket.

comment:2 Changed 12 years ago by KaZeR

  • Status changed from new to assigned

When you enter the City search mode, do you have your country flag left of the text field? Or do you have a grey cross?

comment:3 Changed 12 years ago by Lollisoft

If I remember, there was no country flag. I also have found, when I go back to select the country, the city search would work. One exception, that may be a openstreetmap data problem, is, when you search München in germany, you didn't find it.

When there is no initial country flag, is there a failure in detecting the position => country, or isn't such a country detection done ?

If you work on the search code, the image (http://scap.linuxtogo.org/files/cc0aed1c3b600ae4cbf96d8d898491b3.png) may show you also a problem. You didn't can scroll the list of found cities. So the GUI for searching isn't well.

See related bug. Should this be a separate trac entry ?

Thanks

Lothar

comment:4 Changed 12 years ago by KaZeR

If there is no country flag, then search won't work. (we know it should be more obvious :) ) If there is no country flag, you can set your country by touching the cross, then searching your country. Once you select it, you will be brought back to the town selection. Country detection is currently based upon locale, because we don't have yet the boundaries for every countries. So, check if your locale is set correctly.

About your screenshot, 2 things :

  • you can't currently scroll down the list, that's right. But you should be able to reach your target by specifying more characters in your search
  • i noticed that the internal keyboard keys have the wrong size. Have you applied the recommanded settings for your FR? (icon_size for example) with these settings the keyboard should be fully viewable.

comment:5 Changed 12 years ago by Flohack

Here is a patch against trunk 2062 which adds a 'Town (Intl.)' button to select a country and then a town.

Changed 12 years ago by Flohack

Patch to add a Town (Intl.) button

comment:6 Changed 11 years ago by KaZeR

  • Milestone set to version 0.2.0

comment:7 Changed 11 years ago by KaZeR

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks for the patch, but it's not really needed : when searching for a town, you should have your country flag, left to the area where the text you typed appears.

If your country is known (either by using your gps position, or using your LC_LANG setting) then you should have the flag.

If your country is unknown, then you should have a grey cross. In that case, you won't be able to search for a town.

If you don't have the flag, then you are missing a gfx file. The case occured until recent packages of navit, where the shipped icons in png weren't of the right size accorded to the recommended settings in the xml (32 vs 60). If you still don't see the flag with a recent package, ensure that you have icon_xs set to a value for which you have a country_XX.png file. It mainly applies for the FreeRunner?, or device where you don't use svg files.

If you have either the flag or the grey cross, you can reach the country selection dialog simply by touching the flag/cross, hence the patch isn't required (only one search button, change country if needed only).

I hope theses explanations help, i'm closing the bug. Please reopen if needed.

Note: See TracTickets for help on using tickets.