Opened 12 years ago

Closed 12 years ago

#301 closed enhancement/feature request (fixed)

Recenter the map before cursor reach screen edge, in North orientation

Reported by: Niccolo Owned by: KaZeR
Priority: major Milestone: want patch / contribution
Component: core Version: git master
Severity: Keywords:
Cc:

Description

I was not able to let the map recenter before the cursor reaches the screen edge (say a 20% before), when the map is North oriented.

I read bugs #99 and #153, but it seems that follow="1" and update="1" disables northing of map.

Change History (7)

comment:1 Changed 12 years ago by KaZeR

  • Milestone set to want patch / contribution

follow=1 will force a refresh of map on each new gps event. You might want to try a higher value if refreshing the map on each update is too much for your device.

As discussed in #153, a configurable boundary and context-dependent redraw and zoom would be nice, so i'll tag this ticket as 'want patch' for now.

comment:2 follow-up: Changed 12 years ago by Niccolo

Unfortunately follow=1 will redraw the map following the vehicle orientation, disregarding the orientation="1" (northing) contained into the navit tag. The result is very confusing.

comment:3 in reply to: ↑ 2 Changed 12 years ago by Tinloaf

Replying to Niccolo:

Unfortunately follow=1 will redraw the map following the vehicle orientation, disregarding the orientation="1" (northing) contained into the navit tag. The result is very confusing.

I can't reproduce that. What revision are you using? The code controlling the northing in that case should be from revision 2018.

comment:4 follow-up: Changed 12 years ago by Niccolo

You are right, I was using an older version. With current revision the redraw is oriented as expected.

However, in my opinion, recentering is still suboptimal: when the map is redrawn it seems to me that the vehicle is not placed at the center. Isn't it?

comment:5 in reply to: ↑ 4 ; follow-up: Changed 12 years ago by Tinloaf

Replying to Niccolo:

You are right, I was using an older version. With current revision the redraw is oriented as expected.

However, in my opinion, recentering is still suboptimal: when the map is redrawn it seems to me that the vehicle is not placed at the center. Isn't it?

Horizontally, it should be centered. Vertically it should be (if I remember the code right) at 20% of the height. That's a feature, so you have more map "in front of you", so that you can "look ahead". You would rather want navit to place the vehicle right in the center of the screen?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 12 years ago by Niccolo

Replying to Tinloaf:

Horizontally, it should be centered. Vertically it should be (if I remember the code right) at 20% of the height. That's a feature, so you have more map "in front of you"

In North orientation 20% of the height does not mean more map inf front of you, think you are moving to South.

By the way, I observed the redraw quite a lot, but I'm not so sure it is always at 20% of the height. It seemed a bit chaotic to me. I will try a newer svn version.

comment:7 in reply to: ↑ 6 Changed 12 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from new to closed

Replying to Niccolo:

In North orientation 20% of the height does not mean more map inf front of you, think you are moving to South.

By the way, I observed the redraw quite a lot, but I'm not so sure it is always at 20% of the height. It seemed a bit chaotic to me. I will try a newer svn version.

That's because navit always moves the cursor to the edge of the screen you are driving away from. If you're driving south, the cursor should be near the northern border of the screen. At the moment this is still a bit jumpy, because the headings reported by the GPS aren't always accurate, but we're implementing a filter to minimize that. For now, I think the issue of this ticket is solved - if it's not, please reopen.

Note: See TracTickets for help on using tickets.