Opened 11 years ago

Closed 11 years ago

#346 closed defect/bug (fixed)

CPU usage on route calculation

Reported by: Mithrandir Owned by: KaZeR
Priority: critical Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Navit seems to recalculate the route permanently. At least on my N810 I permanently have 100% CPU usage when routing is active. Imho it should only do when one has left the route, to conserve CPU and power. Also navit would overall run more fluently then.

Attachments (1)

navit.xml (223.7 KB) - added by Mithrandir 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by Mithrandir

I get endlessly the following console output when this occurs:

New clock: DSPClock Got EOS from element "pipeline0". Execution ended after 3597808000 ns. Setting pipeline to PAUSED ... Setting pipeline to READY ... Setting pipeline to NULL ... FREEING pipeline ... Setting pipeline to PAUSED ... Pipeline is PREROLLING ... Pipeline is PREROLLED ... Setting pipeline to PLAYING ...

And everything gets slow...

comment:2 Changed 11 years ago by Mithrandir

  • Priority changed from major to critical

comment:3 Changed 11 years ago by Tinloaf

Navit should not recalculate the route when you don't leave it, and it does not for me. Can anyone reproduce this?

Changed 11 years ago by Mithrandir

comment:4 Changed 11 years ago by Mithrandir

Still present in svn-2239. Are you using the same hardware? Attaching my navit.xml for reference.

comment:5 Changed 11 years ago by Tinloaf

No, I'm not, but I think it is quite improbable that some hardware causes navit to recalculate the route (and probably even rebuild the route graph), although probably a very bad GPS receiver could put you on different roads on each update, what would cause at least the route itself to be rebuilt. In that case, setting "cdf_histsize" in your navit.xml to 4 or 5 could probably help.

comment:6 Changed 11 years ago by Mithrandir

I agree, but setting cdf_histsize did not make any difference. Values I tried were 4,5,6,10. CPU is still maxed out and I cannot perform any user input while routing is active and gps fixed. Perhaps anyone also using the N810 can report if he/she also has the problem. Could also be some library/threading issue on maemo that results in busy waiting due to library implementation, but that's only a guess, since I don't know the code. By the way is there any possibility to set routing priority in navit.xml? Is routing implemented as separate thread or is there some main loop which handles user input and routing somehow?

comment:7 Changed 11 years ago by Udo

I am also on n810 and noticed the same. I also have an ipaq H2210 that was not so fast when running navit. How can we assist infinding the root cause?

comment:8 Changed 11 years ago by Yorick

this seems to be fixed on my FR (running 2308); I think it got fixed in 2307

comment:9 Changed 11 years ago by KaZeR

  • Resolution set to fixed
  • Status changed from new to closed

Since we have report of issue solved, i'm closing the ticket. Please reopen if needed.

Note: See TracTickets for help on using tickets.