Opened 11 years ago

Closed 11 years ago

#359 closed defect/bug (worksforme)

navit crashes when routing is active

Reported by: Mithrandir Owned by: KaZeR
Priority: critical Milestone:
Component: core Version: git master
Severity: Keywords:
Cc:

Description

Navit (svn-2213) crashes after routing has been activated on my N810. I use navit.bin maps from http://downloads.cloudmade.com/europe/germany#breadcrumbs. My navit.xml is attached.

Steps to reproduce: 1.wait for gps fix

  1. select a destination i.e. from bookmarks
  2. navit crashes before a route is being displayed

Console output:

Loaded symbols for /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-xpm.so Reading symbols from /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so...done. Loaded symbols for /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so 0x400d553c in waitpid () from /lib/libc.so.6 #0 0x400d553c in waitpid () from /lib/libc.so.6 #1 0x400829a8 in ?? () from /lib/libc.so.6 Cannot access memory at address 0xf8c Detaching from program: /usr/bin/navit, process 1847

Attachments (1)

navit.xml (218.8 KB) - added by Mithrandir 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by Mithrandir

comment:1 Changed 11 years ago by Mithrandir

  • Resolution set to worksforme
  • Status changed from new to closed

It seems like recent updates broke my navit.xml. After recreating it from scratch the crash does not occur anymore.

Note: See TracTickets for help on using tickets.