Opened 12 years ago

Closed 12 years ago

#362 closed defect/bug (fixed)

Error in openSuSE buildservice related to errors in navit.

Reported by: Worldcitizen Owned by: KaZeR
Priority: major Milestone:
Component: core Version: git master
Severity: Keywords:
Cc: joop_boonen@…

Description

Navit 0.1.0 built without problems.

When I build version navit-0.1.0+svn2218 in openSuSE buildservice I get a few errors:

1) Most important i think. In compatibility between ix86 and x86_64.

<qoute> ... running 02-check-gcc-output ... testing for serious compiler warnings (using /usr/lib/build/checks-data/check_gcc_output) (using .build.log) E: navit 64bit-portability-issue command.c:734, 749, 765, 767 </quote>

2) A randon return value.

<quote> I: Program returns random data in a function E: navit no-return-in-nonvoid-function gui_internal.c:3534 </quote>

3) An error about the debugging information:

<quote> ... running 01-check-debuginfo ... testing for empty debuginfo packages ! ! navit-debugsource-0.1.0+svn2218-14.1.x86_64.rpm: no debug sources, deleting package ! navit-debuginfo-0.1.0+svn2218-14.1.x86_64.rpm: WARNING: this probably means the debug information is invalid ! </quote>

I'm trying to build navit svn for openSuSE. I want to follow the last svn version so this can be thoroughly tested.

Change History (4)

comment:1 Changed 12 years ago by Worldcitizen

Just tested with version 0.1.0+svn2222. RPM package is build without a problem.

Need to test the bin file.

comment:2 Changed 12 years ago by Tinloaf

That's because i applied patches for (1) and (2) in revisions 2221 and 2222 (after almost killing our repository in 2219 :-/). Please let me know if it works.

comment:3 Changed 12 years ago by Worldcitizen

I've just tested it. The build package works perfectly.

The issue is resolved.

comment:4 Changed 12 years ago by Tinloaf

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.