Opened 6 years ago

Closed 5 years ago

#379 closed defect/bug (wontfix)

crashes on attempting to render any text on the map (svn 2310, fedora 11)

Reported by: AdamW Owned by: KaZeR
Priority: critical Milestone:
Component: core Version: svn
Severity: Keywords:
Cc:

Description

I'm putting together a Navit package for Fedora (I previously maintained the Mandriva navit package). I have 0.1.0 built and working well, but it's rather old, so I thought I'd do current svn instead. However, it crashes as soon as it should render any text to the map - with a dead stock navit.xml it crashes immediately on startup (because it starts up centred on the example map), if I enable my GPS and use the maps for my local area, it runs OK when it starts up (with a blank orange canvas in the map area, because the maps for my local area don't cover the default centring position) but as soon as it locks onto my GPS position (and hence should render the map, because my GPS position *is* covered by my local maps), it crashes.

This is with a clean build and install, and a dead stock navit.xml. The only patches in the build are http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/navit/current/SOURCES/navit-0.1.0-static_sample.patch (which stops it trying to download the sample map as part of the build - instead it's provided as one of the source files to the build) and the patch from bug #329 to fix the definition of the 'moc' command (since on fedora it's not plain 'moc', it's 'moc-qt4'). Neither of these should affect this issue at all.

The trace from the crash, with debuginfo packages installed, is:

http://navit.pastebin.com/f16d73d2a

that's from the 'stock navit.xml' case, but the errors in the 'my local maps' case are very similar, with the same freetype-related stuff looking to be at the bottom of the pile.

Change History (2)

comment:1 Changed 6 years ago by AdamW

Martin S. tracked this down to a freetype bug, which I've reported (to RH bugzilla for now) here:

https://bugzilla.redhat.com/show_bug.cgi?id=506840

comment:2 Changed 5 years ago by cp15

  • Resolution set to wontfix
  • Status changed from new to closed

Since not caused by navit, I will change status

Note: See TracTickets for help on using tickets.