Opened 11 years ago

Closed 5 years ago

#399 closed defect/bug (fixed)

Vehicle cursor leave a nasty trail when moving

Reported by: niccolo Owned by: number6
Priority: minor Milestone: version 0.2.1
Component: graphics/gtk_drawing Version: git master
Severity: normal Keywords:
Cc: nick@…

Description

I upgraded Navit from svn-2055 to svn-2391 on my OpenMoko FreeRunner?.

My customized vehicle cursor now leave a nasty trail when moving, it seems that the cursor redraw is broken. The previous version worked nicely.

I attach the screenshot of the bug and the xml of the vehicle cursor.

Attachments (2)

navit-cursor.png (45.3 KB) - added by niccolo 11 years ago.
vehicle-cursor.xml (798 bytes) - added by niccolo 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by niccolo

Changed 11 years ago by niccolo

comment:1 Changed 11 years ago by niccolo

  • Priority changed from major to minor

The problem is caused by having more than one vehicle (4 vheicles in my case) with source="gpsd://localhost", enabled="yes" and active="1".

Setting enabled="no" and active="0" to all except than one, solved the problem.

May be there is a bug in the cursor draw routine (I think the effect in the attached image should not appear) but it is a minor one.

comment:2 Changed 11 years ago by kazer

  • Milestone set to version 0.2.0

comment:3 Changed 11 years ago by kazer

  • Component changed from core to graphics/gtk_drawing
  • Owner changed from KaZeR to cp15

comment:4 Changed 9 years ago by number6

  • Cc nick@… added
  • Owner changed from cp15 to number6

Does this ticket still apply?

Suggestions seem to say no.

Nick

comment:5 Changed 9 years ago by korrosa

This was still happening for me, until I did exactly what Niccolo suggested a few comments up. I'll check again tonight and report back.

comment:6 Changed 7 years ago by usul

Korossa, was this already solved, or is still an issue?

comment:7 Changed 5 years ago by tryagain

  • Resolution set to fixed
  • Severity set to normal
  • Status changed from new to closed

I guess issue was fixed (actually was support request raher than bug report).

Note: See TracTickets for help on using tickets.