Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#401 closed enhancement/feature request (duplicate)

Hospitals are not rendered

Reported by: stuvel.eu Owned by: KaZeR
Priority: major Milestone: version 0.2.0
Component: core Version: git master
Severity: Keywords:
Cc: sybren@…

Description

I added a polygon for the Boven IJ Ziekenhuis (hospital) in Amsterdam: http://www.openstreetmap.org/browse/way/37379077 and tagged it with:

amenity = hospital

name = Boven IJ Ziekenhuis

I'd expect Navit to render the hospital, but unfortunately nothing is shown. I'm certain that I'm using an extract from OSM that contains the hospital, as it also contains changes I made after adding the hospital.

Normally I wouldn't be bothered too much with certain specific items not being shown. However, knowing the locations of hospitals can save lives, and may thus be a nice feature for Navit ;-)

A general solution would be to draw unknown polygon/way/node types in a certain colour and display their name. Even though Navit may not know what to do with them, the viewer might.

Change History (3)

comment:1 Changed 10 years ago by kazer

  • Milestone set to version 0.2.0

It's not rendered because currently this kinds of POI where only parsed as nodes, not areas.

About drawing unknown items, there was 'purple' items some times ago. Maybe it can be reenabled using navit.xml.

comment:2 Changed 10 years ago by stuvel.eu

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 10 years ago by stuvel.eu

Duplicate of #477

Note: See TracTickets for help on using tickets.