Opened 8 years ago

Closed 4 years ago

#419 closed enhancement/feature request (Incomplete/Missing infos)

"Bookmarks" for names in Towns search

Reported by: stuvel.eu Owned by: KaZeR
Priority: major Milestone: version 1.0
Component: core Version: git master
Severity: Keywords:
Cc: sybren@…, http://wiki.test.navit-project.org/index.php/user:usul

Description

It would be nice if the towns search (Actions -> Towns) had a list of bookmarks. I live in Amsterdam, and many of the streets I want to navigate to are in Amsterdam. However, before I can select Amsterdam from the list of towns I have to type at least "amster". Being able to select Amsterdam from a list would be very useful.

Before the user has typed any letters, the list of towns is empty. This provides a nice space to show the list of bookmarks.

If the name "bookmark" is confusing because it is already used somewhere else, "preferred town", "town bookmark", "townmark" or "remembered town" could be usable alternatives.

Change History (5)

comment:1 Changed 8 years ago by stuvel.eu

Perhaps even a choice "the town you're in now" could be added, or a choice of nearby towns.

comment:2 Changed 8 years ago by kazer

  • Milestone set to version 0.2.0

comment:3 follow-up: Changed 7 years ago by kazer

  • Milestone changed from version 0.2.0 to To be discussed - Give your opinion!

We could also display the last searched towns?

comment:4 in reply to: ↑ 3 Changed 7 years ago by stuvel.eu

Replying to http://wiki.navit-project.org/index.php/user:kazer:

We could also display the last searched towns?

That would be sweet! And perhaps the same mechanism for streets as well.

comment:5 Changed 4 years ago by usul

  • Cc http://wiki.test.navit-project.org/index.php/user:usul added
  • Resolution set to Incomplete/Missing infos
  • Status changed from new to closed

You might have seen the new history functionality allready, that introduces a list of items that you visited before. Will this do the job for you?

But yes, we are aware that the lookup mechanism is still unconfortable. Some aspects are caused by the interal structures of Navit, but IMHO a preselection of the current city would be easy to realize.

Note: See TracTickets for help on using tickets.