Opened 12 years ago

Closed 12 years ago

#45 closed defect/bug (duplicate)

The car is not sufficiently visible

Reported by: hafting Owned by: somebody
Priority: major Milestone:
Component: core Version:
Severity: Keywords:
Cc:

Description

The car is hard to spot on the map, for several reasons:

  • It has only one color. Therefore, it does not have good contrast in all cases, since the surroundings vary so much. With a route, the background is dark blue so a lightly colored car might work. Without a route the map is almost white, so a dark car might work.

A multicolor car is better, similar to how street names uses white outlining for better visibility when the black text is printed on a dark red trunk road. The car should _really_ stand out on the map, so it can be found very quickly. Still, it must not cover up a large area. One idea: Consider the "marching ants" border used for selections in gimp and some other drawing software. It is highly visible in all cases. The car outline and direction arrow could be like that. Use two high-contrasting colors, like black+white or black+yellow. Configurable of course, so extra cars can have other colors.

  • The car disappear in some cases. It tends to disappear when standing still - but that is precisely when I have time to look at the map. It also disappears completely with follow=1 - odd.

Change History (1)

comment:1 Changed 12 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22

Note: See TracTickets for help on using tickets.