Opened 8 years ago

Last modified 4 years ago

#476 reopened defect/bug

Some icons don't exist with the extention mentioned in the supplied navit.xml (navit/navit_shipped.xml) file

Reported by: worldcitizen Owned by: KaZeR
Priority: major Milestone: version 0.5.1
Component: core Version: git master
Severity: Keywords: xpm
Cc: worldcitizen, gerrit308@…

Description

These are some examples: navit:displayitem_draw:failed to load icon 'bar.xpm' navit:displayitem_draw:failed to load icon 'shop_grocery.xpm'

If you look in: navit/xpm/Makefile.am You'll see that it's copying over: bar.svg instead of bar.xpm There are more that have a different name

shop_grocery is missing in the Makefile ie it's not copied over even tough is used in the navit_shipped.xml file.

Current both xpm and svg files are used for icons. Wouldn't it be best to only use xpm?

I don't mind creating a patch for these files: svgs += airport.svg svgs += attraction.svg svgs += bank.svg svgs += bar.svg svgs += boat_ramp.svg svgs += bus.svg svgs += cinema.svg svgs += exit.svg svgs += fastfood.svg svgs += firebrigade.svg svgs += fuel.svg svgs += hospital.svg svgs += peak.svg svgs += police.svg svgs += post.svg svgs += shopping.svg svgs += traffic_signals.svg svgs += church.svg

That they will be xpm file, ie xpm_DATA

Attachments (4)

navit-iconsfix.patch (6 bytes) - added by worldcitizen 8 years ago.
The patch is not compleetly ok yet.
navit_icons_su.txt (732 bytes) - added by worldcitizen 8 years ago.
Some icons of which the name in navit/navit_shipped.xmland the available file don't match. This might not be all.
svgs.tar.bz2 (2.0 KB) - added by worldcitizen 8 years ago.
Created svg files from xpm files via convert inkscape for directory navit/navit/xpm/.
trac476-1.diff (25.5 KB) - added by www.google.com/accounts/o8/id?id=aitoawnmmavstbc7qcfucz3hirapbgleh8d5qeu 8 years ago.
navit.xml.diff to cleanup missing icons

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by worldcitizen

  • Cc worldcitizen added

comment:2 Changed 8 years ago by worldcitizen

  • Summary changed from SOme icons don't exist with the extention mentioned in the supplied navit.xml (navit/navit_shipped.xml) file to Some icons don't exist with the extention mentioned in the supplied navit.xml (navit/navit_shipped.xml) file

Changed 8 years ago by worldcitizen

The patch is not compleetly ok yet.

comment:3 Changed 8 years ago by worldcitizen

  • Priority changed from critical to major

Changed 8 years ago by worldcitizen

Some icons of which the name in navit/navit_shipped.xmland the available file don't match. This might not be all.

comment:4 Changed 8 years ago by sera

The following icons are available as png and as svg.

cursor cursor225 cursor450 cursor675 cursor_still navit

which leaves

osd_minus osd_plus 

to be converted from png to svg.

The following are available as xpm and svg.

airport attraction bank bar boat_ramp bus church cinema cursor exit fastfood firebrigade fuel hospital peak police post shopping traffic_signals zoom_in zoom_out

which leaves

bench biergarten boundary_stone bus_halt cafe camping car_dealer castle cemetery dumping_station flag_bk_tr flag_bk_wh flag_bl_wh flag_wh_bk fountain gc_event gc_multi gc_mystery gc_question gc_reference gc_stages gc_tradi gc_webcam golf gui_sound_32 gui_sound_off_32 heliport highway_exit hotel hunting_stand information justice level_crossing library memorial menu military mini_roundabout museum nav_left_1 nav_left_1_32 nav_left_2 nav_left_2_32 nav_right_1 nav_right_1_32 nav_right_2 nav_right_2_32 nav_straight nav_straight_32 parking pharmacy picnic potable_water public_office restaurant restroom ruins school shelter skiing sport swimming telephone theater toggle_fullscreen toilets tower townhall trailerpark unknown viewpoint wifi zoo

to be converted to svg.

So the simplest would be to convert the leftovers (should be done anyway), change the navit.xml to only use svgs and provide an xslt to navit.xml for changing to png if desired. What do you think?

Changed 8 years ago by worldcitizen

Created svg files from xpm files via convert inkscape for directory navit/navit/xpm/.

comment:5 Changed 8 years ago by worldcitizen

The conversion didn't work out yet

comment:6 Changed 8 years ago by www.google.com/accounts/o8/id?id=aitoawnmmavstbc7qcfucz3hirapbgleh8d5qeu

  • Cc gerrit308@… added

Changed 8 years ago by www.google.com/accounts/o8/id?id=aitoawnmmavstbc7qcfucz3hirapbgleh8d5qeu

navit.xml.diff to cleanup missing icons

comment:7 Changed 8 years ago by www.google.com/accounts/o8/id?id=aitoawnmmavstbc7qcfucz3hirapbgleh8d5qeu

Attached a diff to clean up navit_shipped.xml. I:

  1. replaced .xpm files with .svg where they were already available.
  2. deleted all icons referred to for which there are no icons

This will result in more icons being displayed, and they will be resized at compile time by using .png files. Haven't found a working xpm to svg tool, e.g. Inkscape wraps a link to the original .xpm in xml, hardly consider this conversion. Briefly tested on N800 in Toronto area. Previous complaints from Navit about restaurant and parking no longer appear.

comment:8 Changed 8 years ago by www.google.com/accounts/o8/id?id=aitoawnmmavstbc7qcfucz3hirapbgleh8d5qeu

Re: the original comment "Current both xpm and svg files are used for icons. Wouldn't it be best to only use xpm?", it is best to use svg because for at least the Nokia N8x0 we convert svg to presized .png files. These load very fast as no resizing processing is needed (as well as the N8x0 not supporting .svg files in the first place!) For larger screens .svg's might render better than scaled up .xpm files. see Trac 284 for details on the code change made to support that.

comment:9 Changed 4 years ago by usul

  • Resolution set to fixed
  • Status changed from new to closed

We currently working on creating a new concept of unified styles and icons, so we will take care, that there are no broken icon references anymore. https://forum.navit-project.org/viewtopic.php?f=19&t=409

For cleanup reasons, I closed this ticket.

comment:10 Changed 4 years ago by sleske

  • Keywords xpm added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Cleaning up old tickets is a good idea, but only if the problem is actually fixed. So I'm reopening this ticket. The ticket has the keyword "xpm"; if the new concept works, all the "xpm" tickets can probably be closed, including this one.

comment:11 Changed 4 years ago by usul

  • Milestone set to version 0.5.1
Note: See TracTickets for help on using tickets.