Opened 11 years ago

Closed 9 years ago

#488 closed enhancement/feature request (fixed)

Enhancement: support for the Back button on Android devices

Reported by: dandv Owned by: cp15
Priority: minor Milestone: want patch / contribution
Component: port/android Version: git master
Severity: Keywords:
Cc: skliarie, sanderd17@…

Description

Many Android phones have a back button, which is used by most Android applications to go back. It therefore becomes a habit to press the Back button to go back from nested menus.

It would be nice if the Android Navit port supported the Back button.

Change History (9)

comment:1 Changed 10 years ago by openid-provider.appspot.com/skliarie

  • Cc http://openid-provider.appspot.com/skliarie added

comment:2 Changed 10 years ago by openid-provider.appspot.com/skliarie

  • Cc http://openid-provider.appspot.com/skliarie removed

comment:3 Changed 10 years ago by skliarie

  • Cc skliarie added

comment:4 Changed 10 years ago by skliarie

This must be a trivial change... Isn't there any android developers working on navit??

comment:5 Changed 10 years ago by www.google.com/accounts/o8/id?id=aitoawl7apc7fakzgfdv-xjpungewz6blysuohi

  • Cc sanderd17@… added

comment:6 Changed 9 years ago by kazer

  • Milestone set to want patch / contribution

Nobody wants to submit a patch?

comment:7 Changed 9 years ago by sanderd17

The problem is that the menu isn't an android menu, so you need to manually implement it. If it were, there is not much to do. I've been able to get the back button doing something: it exits navit if you press the back button. This is not the wanted behaviour.

comment:8 Changed 9 years ago by ra_sch

Someone must have done something on this. In the latest svn it is working in many cases...

comment:9 Changed 9 years ago by zoff99

  • Resolution set to fixed
  • Status changed from new to closed

seems to work in latest svn

Note: See TracTickets for help on using tickets.