Opened 11 years ago

Closed 9 years ago

#493 closed defect/bug (fixed)

hitting enter in town search prints squares

Reported by: timo lindfors Owned by: cp15
Priority: minor Milestone: version 0.2.1
Component: gui/internal Version: git master
Severity: Keywords:
Cc:

Description (last modified by kazer)

Steps to reproduce:

  • use internal UI
  • click the map
  • click Actions
  • click Town
  • type Helsinki and hit enter (with laptop keyboard, no the on-screen keyboard)

Expected results:

  • navit selects Helsinki as the town

Actual results:

  • navit shows "Helsinki" and a small square and does not find the town because of this.

Change History (3)

comment:1 Changed 11 years ago by timo lindfors

Should this detection be done in gui_internal_keypress_do() or gui_internal_search_changed()?

comment:2 Changed 10 years ago by kazer

  • Description modified (diff)
  • Milestone set to version 0.2.0

comment:3 Changed 9 years ago by woglinde

  • Resolution set to fixed
  • Status changed from new to closed

Hi,

hitting enter selects now the firstentry of the searchlist. So this bug is fixed with revision 3855: http://navit.svn.sourceforge.net/viewvc/navit?view=revision&revision=3855

Note: See TracTickets for help on using tickets.