Opened 10 years ago

Closed 10 years ago

#496 closed defect/bug (fixed)

navit on android: cant not diaplay map

Reported by: vzq4815 Owned by: KaZeR
Priority: major Milestone:
Component: port/android Version: git master
Severity: Keywords:
Cc: skliarie

Description

i install the navit 2666 spk on the Emulator. however, when i start to run it, it shows the nothing but whole yellow page to me.

and when i put the map bin file to the sd card, which i download from the navit_project.org. when navit start up, the GPS starts but then it will automaticlly exit the program.

anyone can help?

Attachments (1)

log.txt (164 bytes) - added by vzq4815 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by vzq4815

comment:1 Changed 10 years ago by openid-provider.appspot.com/skliarie

  • Cc skliarie@… added

Emulator has no GPS fix unless you explicitly tell it: telnet localhost 5554 geo fix 31.6962 35.1142

Even on real hardware (FreeRunner?) navit-svn-2696.apk takes couple minutes to transfor from yellow page to showing data.

IMHO, navit should print something like "Waiting for fix..." and not leave users frustrated with the yellow page.

comment:2 Changed 10 years ago by skliarie

  • Cc skliarie added

comment:3 Changed 10 years ago by openid-provider.appspot.com/skliarie

  • Cc skliarie@… removed

comment:4 Changed 10 years ago by kazer

  • Component changed from core to port/android
  • Resolution set to fixed
  • Status changed from new to closed

The map issue could have been caused by an inconsistent relationship between maptool and navit. It usually occurs when you are using a map made with a different maptool revision than your navit binary. Unfortunately it's hard to tell because the attached log doesn't give much details. Please try with a recent revision of navit (from http://download.navit-project.org for example) and a recent map from http://maps.navit-project.org (if you don't want to process your maps yourself, it's the best option).

About the 'yellow page' : by default, until you get a fix, navit will center the view on the coordinates it was centered last time you used it. If there is no such saved coordinates (in ~/.navit/center.txt by default) it will use the center value configured in navit.xml.

So, if you have a map, but don't see it until you get a fix, you can try to remove the center.txt file and check/change the default coordinates in navit.xml.

Or, more easily, you can touch the screen, go into action, search for a town, and select "View on map". It will center the view on the search result, and next time you startup navit, even if you didn't had a fix, you should see the map.

Since it doesn't seem like a bug to me, i will close the ticket. Hope it helps, feel free to reopen.

Note: See TracTickets for help on using tickets.